Author Topic: Unable to load DSK SaxophoneZ VSTi  (Read 28090 times)

Offline AmericanDiamond

  • Active artist
  • *
  • Posts: 34
Unable to load DSK SaxophoneZ VSTi
« on: March 04, 2009, 08:21:29 »
Happy 2009!  I'm back after several months and after the resolved surround sound/rear track issue.

As some may know, DSK makes incredibly awesome VSTi's that are on the cutting edge of music software.  Among those VSTi's is DSK SaxophoneZ, which is the only FREE quality saxophone VSTi I can find anywhere on the Net.  Impressed, I downloaded it several times only to find that, when I loaded the .dll file in MPT 1.17.02.48, I get the "Exception" error message and the notice that it's not a valid plugin.  I also saw that it has .sem files for it's built-in effects and that it was made with Synth Maker.

What makes it more confusing is that I was able to get DSK mini DRUMZ 2 working with no problems.

If anyone can please help me get this VSTi working in MPT, I would appreciate it to the highest.

Offline Nahkranoth

  • Crazy artist
  • ****
  • Posts: 551
  • Gender: Male
Unable to load DSK SaxophoneZ VSTi
« Reply #1 on: March 04, 2009, 11:07:23 »
Not sure, but it may be due to missing libraries that some of the modules may use. I was able to get some of my plugins working after installing msvc2008 or other libraries.
I have it at home, so will try to check if it's working. Actually, I can't remember now.
And, .sem modules come from Synthedit, not Synthmaker.

Offline Sam_Zen

  • Extreme artist
  • *****
  • Posts: 3,689
    • http://www.xs4all.nl/~samzen/
Unable to load DSK SaxophoneZ VSTi
« Reply #2 on: March 04, 2009, 13:30:34 »
This DSK has some very nice modules.
No problem loading the saxophone VSTi in OMPT (latest beta)
Didn't find any .sem files, just the .dll.

I don't have experience with VSTi plugins, so far I worked with samples.
So after 'Edit' I got the GUI of the saxophone.. Then what ? I don't have a MIDI keyboard, so how do I get sound ?
0.618033988

Offline Rakib

  • Crazy artist
  • ****
  • Posts: 919
  • Operating System: win7x64
Unable to load DSK SaxophoneZ VSTi
« Reply #3 on: March 04, 2009, 13:58:13 »
I downloaded and tested, got no errors or any other problems. maybe it is correct what Nahkranoth about you missin the runtime packages that are required for you to run the vst's?
^^

Offline Saga Musix

  • OpenMPT Developers
  • *****
  • Posts: 7,534
  • aka Jojo
    • Download music, samples, VST plugins: Saga Musix Website
  • Operating System: Windows 10 x64
Unable to load DSK SaxophoneZ VSTi
« Reply #4 on: March 04, 2009, 14:24:18 »
Sam: You can assign the VSTi to an instrument and then play on the pc keyboard, just like you would enter notes into the pattern.
» No support, bug reports, feature requests via private messages - they will not be answered. Use the forums and the issue tracker so that everyone can benefit from your post.

Offline Sam_Zen

  • Extreme artist
  • *****
  • Posts: 3,689
    • http://www.xs4all.nl/~samzen/
Unable to load DSK SaxophoneZ VSTi
« Reply #5 on: March 04, 2009, 20:01:31 »
Thanks Jojo ! Great, my supposition in that direction is confirmed. I'm gonna try out that buddhist monk.. :)
0.618033988

Offline Nahkranoth

  • Crazy artist
  • ****
  • Posts: 551
  • Gender: Male
Unable to load DSK SaxophoneZ VSTi
« Reply #6 on: March 05, 2009, 08:32:57 »
Quote from: "Sam_Zen"
I'm gonna try out that buddhist monk.. :)

I think LOL using that monk is guaranteed :D

[EDIT] To the OP:
It seems if you install some msvc redistributables, DSK_SaxophoneZ will be working OK. Please try and post here whether you succeed or not.

Offline rncekel

  • Workaholic artist
  • ***
  • Posts: 183
Unable to load DSK SaxophoneZ VSTi
« Reply #7 on: March 05, 2009, 12:43:41 »
I haven't had any problem, just download the zip and put it in the directory, then load it with the plugin manager, and sounds great.

Offline Saga Musix

  • OpenMPT Developers
  • *****
  • Posts: 7,534
  • aka Jojo
    • Download music, samples, VST plugins: Saga Musix Website
  • Operating System: Windows 10 x64
Unable to load DSK SaxophoneZ VSTi
« Reply #8 on: March 05, 2009, 17:38:17 »
Delay Lama is fun indeed...
» No support, bug reports, feature requests via private messages - they will not be answered. Use the forums and the issue tracker so that everyone can benefit from your post.

Offline Harbinger

  • Extreme artist
  • *****
  • Posts: 1,146
  • Gender: Male
  • Operating System: Windows XP
Unable to load DSK SaxophoneZ VSTi
« Reply #9 on: March 07, 2009, 00:37:37 »
Yes, the DSK modules are great, but i've also encountered a few problems with them, but all that i've used from DSK have not any trouble loading.

Assuming you're using a typical Windows system, i suggest you separate the .dll and the GUI files -- i believe the the GUI files should go in a separate folder and the .dll OUTSIDE that folder. But most of DSK VSTi's don't use that setup anymore, so you may have an old version. Anyway, try different directory setups within the directory that MPT expects to find your VSTs.

Maybe one of the devs can determine HOW Modplug discerns whether or not a plug-in is a "valid" VST, and let us know...

Offline AmericanDiamond

  • Active artist
  • *
  • Posts: 34
Unable to load DSK SaxophoneZ VSTi
« Reply #10 on: March 12, 2009, 10:49:26 »
Alright, I found the msvc2008 download on Microsoft's site, installed the new runtime, and tried again to load the DSK plugin.  The same thing occurred.

Yes, the .sem files are in a separate folder inside of the plugin folder, and yes I know how to install VST effects and instruments in MPT; this plugin is in the same folder as all the other successful plugins.  I have also tried DSK Synthopia but to no avail.

I do believe I have the latest release of MPT (1.17.02.48), and yes it is on Windows XP.

Offline rncekel

  • Workaholic artist
  • ***
  • Posts: 183
Unable to load DSK SaxophoneZ VSTi
« Reply #11 on: March 12, 2009, 10:56:34 »
Quote
I do believe I have the latest release of MPT (1.17.02.48 )

No, you don't. Last one is 1.17.02.52.
The .sem files should be in a subdirectory named "DSK SaxophoneZ".
Hope this solve it

Offline AmericanDiamond

  • Active artist
  • *
  • Posts: 34
Unable to load DSK SaxophoneZ VSTi
« Reply #12 on: March 12, 2009, 13:15:12 »
Okay, so I didn't have the latest version of MPT.  Well, I tried to load it a third time, and there went the same "Exception" issue.  The .sem files already come in their own folders upon extraction.  I even tried another program designed primarily for VSTs, and the DSK plugins didn't load there at all.

I hope that it's not a PC issue, because I'm not understanding how it's working for everyone else but me.

Thanks for that info.

Offline bvanoudtshoorn

  • Extreme artist
  • *****
  • Posts: 1,053
  • Gender: Male
    • Barryvan
Unable to load DSK SaxophoneZ VSTi
« Reply #13 on: March 12, 2009, 23:14:47 »
Have you tried downloading the files again? Your copy of the plugin itself could be corrupted. Maybe someone here who has the same plugin can compare the hash of their files with yours to check.

Offline AmericanDiamond

  • Active artist
  • *
  • Posts: 34
Unable to load DSK SaxophoneZ VSTi
« Reply #14 on: March 13, 2009, 13:35:11 »
That sounds like a good idea, but I don't know how to do that.  The site I downloaded it from, rekkerd.org, does advise against the use of a download manager, but even using Firefox's built-in downloader was faulty, and I have dial up, so there aren't many options for me in downloading.

In the meantime, someone on the site had the same issue with a similar plugin and got the answer that the container wasn't renamed, which could be causing MPT to not recognize the plugins.

I'm still amazed that the drums and Dreamz plugin installed and worked perfectly fine (maybe because they're relatively small downloads).

If anyone could volunteer to do a hash check, I have the .zip files.  Thanks.