Author Topic: .50 MOD load bug  (Read 3520 times)

Offline Saga Musix

  • OpenMPT Developers
  • *****
  • Posts: 7,071
  • aka Jojo
    • Download music, samples, VST plugins: Saga Musix Website
  • Operating System: Windows 10 x64
.50 MOD load bug
« on: February 17, 2008, 15:09:47 »
Full Version:
OpenMPT v1.17.02.50

Has the bug occured in previous versions? If yes, please specify version(s): (This option is optional, and doesn't need research. But in case you know...)
yes, but not tested which

Description of the bug:
If you changed a generic MOD file (f.e. changing just a sample), you will get this error message with some of them:


How often does it happen?:
Only with certain modules, for example this one.
You either have to fix the mod saver or suppress this message (i'd do the latter one :D)

How to reproduce (step by step description):
change the mod, wait until autosave and see some message boxes :D

Edit: Moved to the issue tracker: http://bugs.openmpt.org/view.php?id=24
« Last Edit: November 06, 2010, 12:39:08 by Jojo »
» No support, bug reports, feature requests via private messages - they will not be answered. Use the forums and the issue tracker so that everyone can benefit from your post.

Offline Relabsoluness

  • OpenMPT Developers
  • *****
  • Posts: 709
(S=O) .50 MOD load bug
« Reply #1 on: February 17, 2008, 21:39:02 »
If the reason for the warning is proper, what's the bug :)   And also, it's not even directly autosave related - the warning can be generated also with ordinary save.

Offline Saga Musix

  • OpenMPT Developers
  • *****
  • Posts: 7,071
  • aka Jojo
    • Download music, samples, VST plugins: Saga Musix Website
  • Operating System: Windows 10 x64
(S=O) .50 MOD load bug
« Reply #2 on: February 18, 2008, 11:40:05 »
Well... do you know how annoying it is to get 10 Message Boxes every minute? I didn't change anything in the pattern order or whatsoever, so the module is in fact valid!
» No support, bug reports, feature requests via private messages - they will not be answered. Use the forums and the issue tracker so that everyone can benefit from your post.

Offline Relabsoluness

  • OpenMPT Developers
  • *****
  • Posts: 709
(S=O) .50 MOD load bug
« Reply #3 on: February 18, 2008, 20:53:02 »
Quote from: "Jojo"
Well... do you know how annoying it is to get 10 Message Boxes every minute?

No, but can imagine. Anyway, the warning is correct in the sense that saving indeed drops a pattern: in the example file the max pattern value in the sequence is 20 but there also exists pattern 21 which is not present in the sequence. The reason for the extra pattern seems to be in bug in the mod loading, but the warning message can be avoided for example by adding pattern 21 to the sequence.

I reopened the report and changed the title from
".50 MOD Autosave error (msgbox pops up)"
to
".50 MOD load bug"