Author Topic: .49 Replay bug on certain modules  (Read 4937 times)

Offline Saga Musix

  • OpenMPT Developers
  • *****
  • Posts: 7,013
  • aka Jojo
    • Download music, samples, VST plugins: Saga Musix Website
  • Operating System: Windows 10 x64
.49 Replay bug on certain modules
« on: December 19, 2007, 16:45:01 »
Full Version:
OpenMPT v1.17.02.49

Has the bug occured in previous versions? If yes, please specify version(s): (This option is optional, and doesn't need research. But in case you know...)
Yes, all versions


Description of the bug:
Showcase: power of darkness
skip to the second pattern and have look at the piano part. the piano is retriggered EVERY line where a "01" is. This is not normal. When I copy the column into another module (Aim for IT playback disabled), this does not happen. no instruments are used in this module, so it is even stranger. It works correctly in IT and XMPlay.
The behaviour is caused by the "Aim for IT playback" option, but it's definitely DIFFERENT to the IT behaviour.

How often does it happen?:
In several modules by this author.
» No support, bug reports, feature requests via private messages - they will not be answered. Use the forums and the issue tracker so that everyone can benefit from your post.

Offline Relabsoluness

  • OpenMPT Developers
  • *****
  • Posts: 709
.49 Replay bug on certain modules
« Reply #1 on: December 19, 2007, 22:04:16 »
Confirmed - thanks for the report. Another source said that "If a sample number is given without a note, Impulse Tracker will play the old note with the new sample.", but if things go wrong compared to Impulse Tracker, apparently that statement forgets to mention that the new sample must not be the same as previous.

A correction to the occurance in other versions: "Aim for IT playback" was introduced only a few versions ago so this bug shouldn't occur in all previous versions.

Also, if this bug becomes too much of a problem, autodetecting the playmode can be disable by adding lines
[Misc]
AutodetectITplaystyle=0
to ini-file(if there already exists line "[Misc]", the lower line can simply be added below it).

Offline Saga Musix

  • OpenMPT Developers
  • *****
  • Posts: 7,013
  • aka Jojo
    • Download music, samples, VST plugins: Saga Musix Website
  • Operating System: Windows 10 x64
.49 Replay bug on certain modules
« Reply #2 on: December 20, 2007, 16:16:46 »
I think that this "sample number retriggers sample" only counts if the sample already stopped. one has to test this.
» No support, bug reports, feature requests via private messages - they will not be answered. Use the forums and the issue tracker so that everyone can benefit from your post.

Offline Saga Musix

  • OpenMPT Developers
  • *****
  • Posts: 7,013
  • aka Jojo
    • Download music, samples, VST plugins: Saga Musix Website
  • Operating System: Windows 10 x64
.49 Replay bug on certain modules
« Reply #3 on: January 27, 2008, 13:50:00 »
Fixed in .50 test build.

EDIT:
It works okay for "power of darkness", but not for "Trance Nation".
testcase
skip to pattern 0 (position 4) and play channels 4 and 5 only. you will hear that the note is retriggered after the "^^" cut command on Line 18 through instrument 14, although it should not (behaviour differs from IT / XMPlay playback).
» No support, bug reports, feature requests via private messages - they will not be answered. Use the forums and the issue tracker so that everyone can benefit from your post.

Offline Relabsoluness

  • OpenMPT Developers
  • *****
  • Posts: 709
.49 Replay bug on certain modules
« Reply #4 on: January 27, 2008, 15:33:35 »
Thanks for the report. Seems to be somewhat different issue but the topic is wide enough to keep the thread open :)

Offline Saga Musix

  • OpenMPT Developers
  • *****
  • Posts: 7,013
  • aka Jojo
    • Download music, samples, VST plugins: Saga Musix Website
  • Operating System: Windows 10 x64
.49 Replay bug on certain modules
« Reply #5 on: March 29, 2008, 21:03:55 »
Look, now it's still wrong on channel 6 and 7! 8) Also at position 4, the samples on channel 6 and 7 are repeating, although they should not.
Sorry if i'm bugging you, but this is kinda strange, isn't it? :D
» No support, bug reports, feature requests via private messages - they will not be answered. Use the forums and the issue tracker so that everyone can benefit from your post.

Offline Relabsoluness

  • OpenMPT Developers
  • *****
  • Posts: 709
.49 Replay bug on certain modules
« Reply #6 on: March 29, 2008, 21:28:09 »
Quote from: "Jojo"
Look, now it's still wrong on channel 6 and 7! 8) Also at position 4, the samples on channel 6 and 7 are repeating, although they should not.
Sorry if i'm bugging you, but this is kinda strange, isn't it? :D

If things are not fixed, it's of course worth bugging about. And anyway, I think this is that kind of bug that without relentless bug reports it  might never get fixed ;)

Offline Saga Musix

  • OpenMPT Developers
  • *****
  • Posts: 7,013
  • aka Jojo
    • Download music, samples, VST plugins: Saga Musix Website
  • Operating System: Windows 10 x64
.49 Replay bug on certain modules
« Reply #7 on: April 14, 2008, 18:42:25 »
Whoooa, thank you :) Finally, all modules sound right!
» No support, bug reports, feature requests via private messages - they will not be answered. Use the forums and the issue tracker so that everyone can benefit from your post.