Row numbers are cut off

Started by Xenesis, January 18, 2023, 13:38:40

Previous topic - Next topic



the row numbers are cut off. Is this normal? I don't think so. Is there a way to change that?

Saga Musix

Well, "normal" in the sense that OpenMPT is really not optimized for fractional screen scaling. It looks like you're using 125% scaling, which is probably about the worst when it comes to scaling small pixel-accurate layouts in Windows. The font used for the pattern row indication scales with the Windows screen scaling but the pattern contents don't scale the same way, which leads to these sort of display issues with this scaling factor.

You could try setting the hidden setting "Display.HighResUI" to 1 instead of 0, and choose a bigger pattern font. That might look a bit more pleasing to the eyes.
» No support, bug reports, feature requests via private messages - they will not be answered. Use the forums and the issue tracker so that everyone can benefit from your post.

David B

I've also noticed this problem when I run a UHD (3840 x 2160) monitor at 200% Windows scaling. The problem also seems to happen with other Windows scaling values which aren't 100%, e.g. 125%, 150%, 175%, 225%. It's fine at 100% scaling. I restarted OpenMPT each time I changed a scaling value.

It's not a huge deal because I can work-out the row numbers anyway, although it looks a bit odd.

I tried setting "Display.HighResUI" to 1, however it looked worse.

Let me know if you want me to try anything else, provide screenshots, etc.


100% Windows scaling is horribly small, so I use 125%. It looks fine in OpenMPT if I use a bigger font size.

David B

Okay, I now see what you both mean about increasing the pattern font size. It increases the height of the rows, and then the row numbers are no longer cut off.