Author Topic: Can't delete individual volume entries in pattern editor  (Read 3041 times)

Offline oxxi

  • Inspired artist
  • **
  • Posts: 64
    • my computer musiks
  • Operating System: Win 7
Can't delete individual volume entries in pattern editor
« on: February 02, 2014, 23:11:12 »
I remember being able to delete the volume for each individual step in the pattern editor. Has this ability been removed? I have tried setting clear field and clear field IT Style to the delete key and none seem to work. Also I can't seem to interpolate the volume anymore either, at least it doesn't seem to behave the same way as before. Very strange behavior in OpenMpt since the last version, it's a little bit more quirky. For example if I make a channel 'surround' and then adjust the volume for that same channel the 'surround' button becomes un-selected and I have to re-select again. Anyways maybe you guys can clue me in on what could be wrong, or if I'm becoming delusional. :) Also I included a screenshot of what I'm trying to edit. I'm trying to interpolate the volume from 56 to 00. When I try to interpolate it just becomes all 00 for the volume. Also I can't delete just the volume. I have to delete the whole note. Anyways I remember in previous versions that in order interpolate the volume there can't be any volume notes in between the starting and ending value. I've tried that as well but still no luck. screenshot Link below:

https://www.dropbox.com/s/wawatpocepx4si8/Screenshot%202014-02-02%2014.52.12.png
////

Offline Saga Musix

  • OpenMPT Developers
  • *****
  • Posts: 7,333
  • aka Jojo
    • Download music, samples, VST plugins: Saga Musix Website
  • Operating System: Windows 10 x64
Re: Can't delete individual volume entries in pattern editor
« Reply #1 on: February 02, 2014, 23:21:11 »
Quote
I remember being able to delete the volume for each individual step in the pattern editor. Has this ability been removed?
The delete shortcut works the same for every cell type, and I cannot recall there being a special shortcut just for the volume column. Are you maybe trying to delete those half-visible volume commands? Those just display the default volume and are purely demonstrative. ;) If they confuse you, you can disable them from the general settings tab ("Show default volume commands").

Quote
When I try to interpolate it just becomes all 00 for the volume.
That's, again, because the v56 commands there don't really exist. When interpolating between an empty and a non-empty cell, OpenMPT will repeat the value from the non-empty cell throughout the whole selection - this is intended behaviour.

Quote
Very strange behavior in OpenMpt since the last version, it's a little bit more quirky. For example if I make a channel 'surround' and then adjust the volume for that same channel the 'surround' button becomes un-selected and I have to re-select again.
You seem to be referring to the quick channel settings dialog, and that bug seems to have been there since forever (it's a relatively new feature so "forever" means about two years ;) ), that's definitely no new quirkiness.

Quote
screenshot Link below:
You may also want to move the separator between the upper control view and the pattern content up a bit, you're wasting almost 100 pixels of pattern space there. ;)
« Last Edit: February 02, 2014, 23:33:20 by Saga Musix »
» No support, bug reports, feature requests via private messages - they will not be answered. Use the forums and the issue tracker so that everyone can benefit from your post.

Offline oxxi

  • Inspired artist
  • **
  • Posts: 64
    • my computer musiks
  • Operating System: Win 7
Re: Can't delete individual volume entries in pattern editor
« Reply #2 on: February 02, 2014, 23:36:21 »
Ah now I'm stress free. Disabling the 'show default volume commands' did the trick. Now I can interpolate as before! I swear though that the 'surround' bug was not there before but I guess I am delusional, haha. ;D Well thank you very much for the clear up. Now I can get back to composing.
////

Offline Saga Musix

  • OpenMPT Developers
  • *****
  • Posts: 7,333
  • aka Jojo
    • Download music, samples, VST plugins: Saga Musix Website
  • Operating System: Windows 10 x64
Re: Can't delete individual volume entries in pattern editor
« Reply #3 on: February 02, 2014, 23:41:00 »
Ah now I'm stress free. Disabling the 'show default volume commands' did the trick. Now I can interpolate as before!
As said, this setting is purely cosmetic, interpolating works the same way no matter whether it's enabled or not. The setting is just a visual guidance to indicate the default sample volume. I thought it would be somewhat obvious that these volume commands aren't "real" as their colour is different from normal volume commands.

I swear though that the 'surround' bug was not there before but I guess I am delusional, haha. ;D
Nope, the code for this bug to happen most definitely has always been there. You probably just have not been using the volume slider in that dialog before.
» No support, bug reports, feature requests via private messages - they will not be answered. Use the forums and the issue tracker so that everyone can benefit from your post.