Author Topic: .41 MDA Degrade plugin causing problems  (Read 6226 times)

Offline fisk0

  • Inspired artist
  • **
  • Posts: 84
  • Gender: Male
    • http://medlem.spray.se/fisk0
  • Operating System: Windows 7
.41 MDA Degrade plugin causing problems
« on: April 04, 2006, 11:33:26 »
I've made a song which is using two mda Degrade VST effects.
(the first was set to Channels 1 and 2, and the second to Channel 3)
Adding one seemed to work fine, but when I added the other OpenMPT flooded me with error messages like:
"The plugin mda Degrade threw an exception in processReplacing. It has automatically been set to "Bypass"."
and then lots of:
"Exception in ProcessVSTEvents() (Plugin=mda Degrade, pEventList:00C3B818, numEvents:64, MidicodeCh:0, MidicodeEv:224, MidicodeNote:0, MidicodeVel:64)"
"Exception in Dispatch(72) (Plugin="mda Degrade")!"
"Exception in Dispatch(12) (Plugin="mda Degrade")!"
"Exception in Dispatch(8) (Plugin="mda Degrade")!"
(the last one at least 3 times)

And when switching between "Patterns" and "General" view I get more of them, this time with "Dispatch(7)" and "(6)".
And when shutting down the program I get an "Dispatch(1)" error.

This also happened in OpenMpt .39, and the old closed source MPT crashes without errors (though I know I've used multiple "mda Degrade" effects in songs in some older versions of closed MPT.)

Offline rewbs

  • OpenMPT Developers
  • *****
  • Posts: 578
.41 MDA Degrade plugin causing problems
« Reply #1 on: April 04, 2006, 13:02:10 »
I think MDA Degrade is a dodgy plugin ( http://www.kvraudio.com/forum/viewtopic.php?p=593728 ), but maybe we should somehow be handling the problems more gracefully.

Offline fisk0

  • Inspired artist
  • **
  • Posts: 84
  • Gender: Male
    • http://medlem.spray.se/fisk0
  • Operating System: Windows 7
.41 MDA Degrade plugin causing problems
« Reply #2 on: April 05, 2006, 21:55:55 »
Quote from: "rewbs"
I think MDA Degrade is a dodgy plugin ( http://www.kvraudio.com/forum/viewtopic.php?p=593728 ), but maybe we should somehow be handling the problems more gracefully.


Strange, I've never had any problems with MDA Degrade before (though I've not been using it that much). It's just strange that it crashes when I load two copies of it, I don't even have to change any of it's settings - and still I've successfully used more than four in some songs I made a couple of years ago.

Offline rewbs

  • OpenMPT Developers
  • *****
  • Posts: 578
.41 MDA Degrade plugin causing problems
« Reply #3 on: April 11, 2006, 23:42:05 »
Quote from: "fisk0"
Quote from: "rewbs"
I think MDA Degrade is a dodgy plugin ( http://www.kvraudio.com/forum/viewtopic.php?p=593728 ), but maybe we should somehow be handling the problems more gracefully.


Strange, I've never had any problems with MDA Degrade before (though I've not been using it that much). It's just strange that it crashes when I load two copies of it, I don't even have to change any of it's settings - and still I've successfully used more than four in some songs I made a couple of years ago.


I'm closing this because I think it's a plugin issue. It's possible we didn't crash with versions of MPT from several years ago because we were not using som many VST features before, so we were not stressing the plug as much.  

As of 1.17.02.42, the user will be warned when loading MDA Degrade, and recommended a selection of alternative bitcrushers.