8 key (play row) not always working

Started by Really Weird Person, December 12, 2008, 01:43:47

Previous topic - Next topic

Really Weird Person

Full Version:
OpenMPT v1.17.02.52

Has the bug occured in previous versions? If yes, please specify version(s): (This option is optional, and doesn't need research. But in case you know...)

Description of the bug:
Every once in a while, the home row 8 key (the key between and above the U and I keys) stops working. This does not appear to affect the 8 key on the num pad, however.

How often does it happen?:
It does not happen often, but it is annoying when it does.

How to reproduce (step by step description):
I am not exactly sure how it would be reproduced.


gotta watch on those different character maps, maybe sometime you switch to another by accident and the "8" key won't be the 8 anymore. :)
These kind of trips happened with me a few times before.
(numpad keys should stay the same no matter what you do)
I'm as calm as a synth without a player.  (Sam_Zen)


Are you on a laptop that has an fn key? If so, then the 8 could become a different key. Or perhaps using language support it changes. I don't really see an OpenMPT bug here, but maybe I'm wrong. :)
"Heh, maybe I should've joined the compo only because it would've meant I wouldn't have had to worry about a damn EQ or compressor for a change. " - Atlantis
"yes.. I think in this case it was wishful thinking: MPT is makng my life hard so it must be wrong" - Rewbs

Really Weird Person

Actually, I am using a tablet PC (in tablet mode) (folded down with the screen facing you) and On-Screen Keyboard. The 8 has no function. I tried it on two other computers (a desktop and a laptop), and it worked on the desktop, but not on the laptop. I tried the other nine on all three of the computers, and they worked.


I'm as calm as a synth without a player.  (Sam_Zen)

Really Weird Person

That is an interesting emoticon you have there, Psishock. It looks like one that may be used for confusion.


What a careful and accurate observation RWP. I may say that i haven't got any idea what could cause those strange behaviors on those portable computers at this point. (Since we have covered most of the issues that passed my mind)
I'm as calm as a synth without a player.  (Sam_Zen)

Saga Musix

Sounds like a PEBKAC or hardware issue, but nothing related to OpenMPT.
» No support, bug reports, feature requests via private messages - they will not be answered. Use the forums and the issue tracker so that everyone can benefit from your post.