Author Topic: .50 Song Properties not saved properly  (Read 6090 times)

Offline BooT-SectoR-ViruZ

  • Workaholic artist
  • ***
  • Posts: 468
    • http://breakcorezecke.de
.50 Song Properties not saved properly
« on: February 01, 2008, 22:19:50 »
Full Version:
OpenMPT v1.17.02.50

Has the bug occured in previous versions? If yes, please specify version(s):
NO!

Description of the bug:
modplug doesn't save song properties of one specific module properly...
i assumed it might be connected to tempo>255 but it's not.

originally the song is supposed to use rc3 mixing, modern tempo mode and have a tempo of 280 at tickspeed 3
when i open it with the current version it will use original mixing, classic tempo mode and will have 255 at tickspeed 3
also .50 will not recognize which version the song was created and last saved with.

no problems when opening with .48 though.
.49 didn't have any problems either if i remember correctly.


How often does it happen?:
always with this one specific module - no problems with similar modules though

How to reproduce (step by step description):
developers will be provided with a link to the module after requesting it
10 years on ModPlug... f#cking hell...

Soundcloud for B-S-V | Soundcloud for DX4-100 | Bandcamp for B-S-V

Offline Saga Musix

  • OpenMPT Developers
  • *****
  • Posts: 6,702
  • aka Jojo
    • Download music, samples, VST plugins: Saga Musix Website
  • Operating System: Windows 10 x64
Re: (S=O) .50 Song Properties not saved properly
« Reply #1 on: February 01, 2008, 22:55:26 »
Quote from: "BooT-SectoR-ViruZ"

also .50 will not recognize which version the song was created and last saved with.

i also wondered about this one already.
» No support, bug reports, feature requests via private messages - they will not be answered. Use the forums and the issue tracker so that everyone can benefit from your post.

Offline Relabsoluness

  • OpenMPT Developers
  • *****
  • Posts: 709
.50 Song Properties not saved properly
« Reply #2 on: February 02, 2008, 15:00:21 »
Damn, this is quite bad bug. Loading of IT files might fail causing song properties(tempo, volume levels etc.) and certain (extended)instrument properties to be left unloaded. This is most likely to occur with IT files made with older version but saved with .50, but can also occur for files saved with older versions. If one saves the file after the incomplete loading, those properties will be lost.

Edit: Corrected the description

Offline BooT-SectoR-ViruZ

  • Workaholic artist
  • ***
  • Posts: 468
    • http://breakcorezecke.de
.50 Song Properties not saved properly
« Reply #3 on: February 02, 2008, 16:47:55 »
the song was created with .48 or .49

Quote from: "Relabsoluness"
There are workarounds, but for now I just hope this hasn't caused bad problems.

nope... as long as i load the module with .48 everything is fine
10 years on ModPlug... f#cking hell...

Soundcloud for B-S-V | Soundcloud for DX4-100 | Bandcamp for B-S-V

Offline Relabsoluness

  • OpenMPT Developers
  • *****
  • Posts: 709
.50 Song Properties not saved properly
« Reply #4 on: February 02, 2008, 19:58:58 »
Quote from: "BooT-SectoR-ViruZ"
the song was created with .48 or .49

OK, yes it seems that the loading may fail regardless of the version with which the file was last saved with (see my previous post); 'created with'-version doesn't matter.

Offline le_parasite

  • Inspired artist
  • **
  • Posts: 55
  • http://www.facebook.com/Le.parasite.000
    • FACEBOOK
  • Operating System: Windows SEVEN 64bit
.50 Song Properties not saved properly
« Reply #5 on: February 14, 2008, 13:26:43 »
In "Instruments" pitch tempo / lock" value is lost too when the song is closed...

Offline Relabsoluness

  • OpenMPT Developers
  • *****
  • Posts: 709
.50 Song Properties not saved properly
« Reply #6 on: February 14, 2008, 21:39:25 »
Quote from: "le_parasite"
In "Instruments" pitch tempo / lock" value is lost too when the song is closed...

Indeed that's among the extended instrument properties whose loading may fail, but a slight correction though. The property is not lost when saving, but instead it's not loaded correctly - opening the file in version .48 or .49 works(?) fine.

Offline le_parasite

  • Inspired artist
  • **
  • Posts: 55
  • http://www.facebook.com/Le.parasite.000
    • FACEBOOK
  • Operating System: Windows SEVEN 64bit
.50 Song Properties not saved properly
« Reply #7 on: February 14, 2008, 23:12:57 »
Quote from: "Relabsoluness"
Quote from: "le_parasite"
In "Instruments" pitch tempo / lock" value is lost too when the song is closed...

Indeed that's among the extended instrument properties whose loading may fail, but a slight correction though. The property is not lost when saving, but instead it's not loaded correctly - opening the file in version .48 or .49 works(?) fine.



yeah, I was glad to see that! :)

Offline Saga Musix

  • OpenMPT Developers
  • *****
  • Posts: 6,702
  • aka Jojo
    • Download music, samples, VST plugins: Saga Musix Website
  • Operating System: Windows 10 x64
.50 Song Properties not saved properly
« Reply #8 on: February 15, 2008, 09:50:15 »
any chance that there will be a quick fix soon...?
» No support, bug reports, feature requests via private messages - they will not be answered. Use the forums and the issue tracker so that everyone can benefit from your post.

Offline le_parasite

  • Inspired artist
  • **
  • Posts: 55
  • http://www.facebook.com/Le.parasite.000
    • FACEBOOK
  • Operating System: Windows SEVEN 64bit
.50 Song Properties not saved properly
« Reply #9 on: February 16, 2008, 18:26:19 »
Quote from: "Jojo"
any chance that there will be a quick fix soon...?


it's a major bug that prevent me from further use.

Offline Relabsoluness

  • OpenMPT Developers
  • *****
  • Posts: 709
.50 Song Properties not saved properly
« Reply #10 on: February 17, 2008, 00:31:30 »
Quote from: "Jojo"
any chance that there will be a quick fix soon...?

Things are in a state that a quick fix doesn't seem likely. If you really want to use .50 despite all its bad bugs(this, the MIDI mapping bug, and who knows what else), you can try a workaround for this bug:

When opening of a IT-file last saved with some earlier version works correctly, in song properties set all modflags to zero, don't add any MIDI mapping entries and set "restart"-setting in general tab to zero. Such IT file saved with .50 should also load fine in .50.

Offline Saga Musix

  • OpenMPT Developers
  • *****
  • Posts: 6,702
  • aka Jojo
    • Download music, samples, VST plugins: Saga Musix Website
  • Operating System: Windows 10 x64
.50 Song Properties not saved properly
« Reply #11 on: March 29, 2008, 21:11:07 »
It seems to be fixed! :)
» No support, bug reports, feature requests via private messages - they will not be answered. Use the forums and the issue tracker so that everyone can benefit from your post.