Author Topic: Test builds  (Read 38227 times)

Offline BooT-SectoR-ViruZ

  • Workaholic artist
  • ***
  • Posts: 469
    • http://breakcorezecke.de
Test builds
« Reply #45 on: February 01, 2008, 21:58:49 »
edit: made a bug report
10 years on ModPlug... f#cking hell...

Soundcloud for B-S-V | Soundcloud for DX4-100 | Bandcamp for B-S-V

Offline Relabsoluness

  • OpenMPT Developers
  • *****
  • Posts: 714
Test builds
« Reply #46 on: February 02, 2008, 15:11:13 »
A major bug has been found in .50 (see the bug report for details) which can cause data loss.

Offline bvanoudtshoorn

  • Extreme artist
  • *****
  • Posts: 1,053
  • Gender: Male
    • Barryvan
Test builds
« Reply #47 on: February 25, 2008, 10:12:48 »
I must admit that I've switched back to 0.49, following the 0.50 release. There are a couple of reasons for this. The first (and most important) is that the "fixed" VST volume handling has seriously borked my plugins which already handled the volume correctly. Volume commands aren't sent reliably, regardless of what settings I choose in the instrument. It's possible to get it to work by editing the song settings every time, but that's just a pain. Also, there's that major bug to do with all the song properties, which is very annoying.

Is it possible to achieve the "normal" plugin volume handling (per channel, *not* per instrument) in 0.50?

Offline LPChip

  • Administrator
  • *****
  • Posts: 5,125
    • http://lpchip.nl
  • Operating System: Windows 10 Pro x64
Test builds
« Reply #48 on: February 25, 2008, 12:16:48 »
Quote from: "bvanoudtshoorn"
Is it possible to achieve the "normal" plugin volume handling (per channel, *not* per instrument) in 0.50?


I think, its safe to say that this is nearly impossible, because its always possible to have one effect on several channels, and setting the volume on one will make it affective on all the channels. Do note that if you talk about the channel volume itself, that the VST effects are being called AFTER the channel volume.

Basically it goes like this:

Sample/instrument -> Channel -> Channel settings -> plugin -> master

That means if you use a VSTi, it will skip channel, and channel settings. Well skip, the sound isn't being altered because there's no sound at that stage to alter.
"Heh, maybe I should've joined the compo only because it would've meant I wouldn't have had to worry about a damn EQ or compressor for a change. " - Atlantis
"yes.. I think in this case it was wishful thinking: MPT is makng my life hard so it must be wrong" - Rewbs

Offline bvanoudtshoorn

  • Extreme artist
  • *****
  • Posts: 1,053
  • Gender: Male
    • Barryvan
Test builds
« Reply #49 on: February 25, 2008, 12:21:48 »
Sorry - I meant MIDI channel. :D

But thanks LP - that explains it a bit better for me.

My problem, though, is that I use multi-channel plugs, which are velocity-sensitive. So with the "standard" settings, I both lose the velocity sensitivity (a note played piano is just a quieter version of a forte note, *not* a different sound), and what I get is blanketed across. So I can't, for example, have two notes (in the same plug, let alone the same midi channel), playing at different velocities.

So basically, I want the old behaviour, where each note is sent with an accompanying velocity message to the plug, without *any* volume handling whatsoever on MPT's part. Just a straight pass-through.

Hope that explains it a bit better. :P

Offline Relabsoluness

  • OpenMPT Developers
  • *****
  • Posts: 714
Test builds
« Reply #50 on: February 25, 2008, 21:56:22 »
Quote from: "bvanoudtshoorn"
So basically, I want the old behaviour, where each note is sent with an accompanying velocity message to the plug, without *any* volume handling whatsoever on MPT's part. Just a straight pass-through.

Could you provide a test case where the new behavior fails: in all tests I've tried the old velocity behavior seems working. For example playing notes with different velocity with the same plugin works fine. If there is something buggy with this (too), it would be good to have it fixed in the next test build, which is to be a bug fix build.

Offline Relabsoluness

  • OpenMPT Developers
  • *****
  • Posts: 714
Test builds
« Reply #51 on: March 29, 2008, 17:39:11 »
A new test build(1.17.02.51) is available in SVN. Mostly bug fixes.

NOTE: Use with care.

Long, detailed list of changes again - some important ones are bolded:

VST related:
------------
[Fix] Fix to crash when loading Olga-VST(and some other plugs as well?).
[Fix] Miscellaneous memory handling fixes. Although it's not likely, checking whether the Kontakt2 related bugs (Bug726) and (Bug1786) are solved would be appreciated.
[Mod] When loading plug information at startup, checking whether files of cached plugs exists, and inform if not.

MIDI related:
-------------
[Fix] Fix to MIDI mapping not checking MIDI event, which could cause events like pitch bend to trigger some mapping item.
[Fix] Fix to wrong notes on MIDI drum export.
[Fix] Possible crash when exporting module with more than 64 channels to MIDI.
[Fix] Muted channels should now be excluded in MIDI export.

Changes in 'IT-style' playflag:
--------------------------
[Fix] Tentative fix for envelope resetting on new instrument.
[Fix] Tentative fix for bidi loop resetting.
[Fix] Tentative fix for plain instrument triggering note after note cut.

GUI/usability:
--------------
[New] Unmute all(on transition) shortcutkeys should now work in orderlist context
[New] Half/double pattern rownumber buttons to pattern properties dialog.
[New] Channel status in status bar now show channel volume info.

[Mod] Modified flag is not set when sliding tempo/global volume slider for MOD file.
[Mod] When setting instrument pan, checking whether instrument samples have set pan enabled and optionally disabling them.
[Mod] Disabled Set Pan in sample tab for XM
[Mod] Show prev/next pattern now shows pattern over +++ orderlist items
[Mod] Disabled setting channel pan for MOD/XM in general view.

[Fix] Paste for pattern effectdata was broken for MOD. Broken probably since .46
[Fix] Fix to severe memory leak in tree view occuring when browsing module samples/instruments.
[Fix] Fix to mptm-files not showing in tree view file browser.
[Fix] Fix to possible crash when browsing modules in treeview.
[Fix] Non existent channels existed in channel control in general tab.
[Fix] Fix for faulty tabs when switching between modtypes with and without instrumenttab.
[Fix] Mixmode-tooltip in general tab was shown with unrelated controls
[Fix], [Fix] Continuous pattern navigation fixes.
[Fix] Keyboard split related fix.
[Fix] Pixel garbage bug might now appear less frequently.


Misc:
-----
[Fix] Extended song/instrument properties were not always loaded correctly for IT in version .50.
[Fix] Pitch/tempo lock was lost on first instrument when opening instrument tab for the first time.
[Fix] Validating buffer length setting read from INI-file to prevent the impression that it can be set < 10.
[Fix] Finetune setting was ignored when converting MOD->IT.
[Reg] Buggy rearrange samples is no longer available.


Executable hashes:
MD5  : ed60357307bed34dd5c5d08067a6349f
SHA-1: 1c3813fd8464d5571d195eaa8fc91fe28e5bfaa2

Offline Saga Musix

  • OpenMPT Developers
  • *****
  • Posts: 7,347
  • aka Jojo
    • Download music, samples, VST plugins: Saga Musix Website
  • Operating System: Windows 10 x64
Test builds
« Reply #52 on: March 29, 2008, 20:39:01 »
That's one big update! Thank you very very much!
In case someone is wondering where this can be obtained:
http://modplug.svn.sourceforge.net/viewvc/modplug/trunk/OpenMPT/mptrack/bin/
» No support, bug reports, feature requests via private messages - they will not be answered. Use the forums and the issue tracker so that everyone can benefit from your post.

Offline Sam_Zen

  • Extreme artist
  • *****
  • Posts: 3,689
    • http://www.xs4all.nl/~samzen/
Test builds
« Reply #53 on: March 29, 2008, 23:30:14 »
Thanks indeed. Nice job!
0.618033988

Offline le_parasite

  • Inspired artist
  • **
  • Posts: 58
  • http://www.facebook.com/Le.parasite.000
    • FACEBOOK
  • Operating System: Windows 10
Test builds
« Reply #54 on: March 30, 2008, 02:05:53 »
thanks for the job, I hope I'll can use fuly this version as I did with releases before .50!
L∑ PДRДSiT∑______________________________________
I ғᴀᴄᴇʙᴏᴏᴋ I ᴛᴡɪᴛᴛᴇʀ I sᴏᴜɴᴅᴄʟᴏᴜᴅ I ʙᴀɴᴅᴄᴀᴍᴘ

Offline Snu

  • Workaholic artist
  • ***
  • Posts: 320
  • Gender: Male
    • http://www.snuq.com
  • Operating System: Windows 7 64bit
Test builds
« Reply #55 on: March 30, 2008, 09:49:11 »
great! thanks for the update, i had to downgrade back to .48 after .50 had some big issues :\
small bug, the vst plugin scan doesnt work right with plugins that have more than one '.' in the file name (ie, it claims its unable to find 'dominion v1.2.dll', but the plugin loads up fine). also, the buffer issue isnt quite fixed, but i posted in that thread.

is there any reason these builds arent on sourceforge download page? too unstable?

Offline Saga Musix

  • OpenMPT Developers
  • *****
  • Posts: 7,347
  • aka Jojo
    • Download music, samples, VST plugins: Saga Musix Website
  • Operating System: Windows 10 x64
Test builds
« Reply #56 on: March 30, 2008, 10:58:42 »
Snu, good discovery. Look at this thread, i had similar issues with VSTs :)
» No support, bug reports, feature requests via private messages - they will not be answered. Use the forums and the issue tracker so that everyone can benefit from your post.

Offline bvanoudtshoorn

  • Extreme artist
  • *****
  • Posts: 1,053
  • Gender: Male
    • Barryvan
Test builds
« Reply #57 on: March 30, 2008, 12:20:32 »
Wow, thanks devs! Great work. This is a milestone build for me, 'cos it's the first time that my plugs seem to all work nicely. :)

Great stuff.

Offline Relabsoluness

  • OpenMPT Developers
  • *****
  • Posts: 714
Test builds
« Reply #58 on: March 30, 2008, 21:58:44 »
Quote from: "Snu"
is there any reason these builds arent on sourceforge download page? too unstable?

Too unstable? :) Won't go into details, but there are various reasons. But it's definitely intention to get new build in sourceforge at some point.

Quote from: "bvanoudtshoorn"
Wow, thanks devs!

I wasn't quite informative in the build description, so it's worth noting that plural form is indeed encouraged ;)

Offline BooT-SectoR-ViruZ

  • Workaholic artist
  • ***
  • Posts: 469
    • http://breakcorezecke.de
Test builds
« Reply #59 on: March 31, 2008, 06:48:36 »
THX!
10 years on ModPlug... f#cking hell...

Soundcloud for B-S-V | Soundcloud for DX4-100 | Bandcamp for B-S-V