Author Topic: .45 problem setting buffer length under 10ms  (Read 5385 times)

Offline Snu

  • Workaholic artist
  • ***
  • Posts: 320
  • Gender: Male
    • http://www.snuq.com
  • Operating System: Windows 7 64bit
.45 problem setting buffer length under 10ms
« on: October 31, 2006, 22:31:00 »
if you try to set buffer length under 10ms in the settings dialog it will automatically set it to 100ms.
its still possible to change it to under 10ms by editing the config file however, and mpt seems quite capable of playing songs at low buffer lengths.

Offline LPChip

  • Administrator
  • *****
  • Posts: 5,101
    • http://lpchip.nl
  • Operating System: Windows 10 Pro x64
.45 problem setting buffer length under 10ms
« Reply #1 on: August 14, 2007, 20:55:42 »
Bumping old bugs...
"Heh, maybe I should've joined the compo only because it would've meant I wouldn't have had to worry about a damn EQ or compressor for a change. " - Atlantis
"yes.. I think in this case it was wishful thinking: MPT is makng my life hard so it must be wrong" - Rewbs

Offline Saga Musix

  • OpenMPT Developers
  • *****
  • Posts: 7,095
  • aka Jojo
    • Download music, samples, VST plugins: Saga Musix Website
  • Operating System: Windows 10 x64
.45 problem setting buffer length under 10ms
« Reply #2 on: March 29, 2008, 21:12:47 »
Still happens here :\
» No support, bug reports, feature requests via private messages - they will not be answered. Use the forums and the issue tracker so that everyone can benefit from your post.

Offline Relabsoluness

  • OpenMPT Developers
  • *****
  • Posts: 709
.45 problem setting buffer length under 10ms
« Reply #3 on: March 29, 2008, 21:15:11 »
Setting the buffer length below 10 should no longer be possible even from INI file, so if, despite all efforts, the buffer can't be set < 10 ms, then things work as intended.

Offline Saga Musix

  • OpenMPT Developers
  • *****
  • Posts: 7,095
  • aka Jojo
    • Download music, samples, VST plugins: Saga Musix Website
  • Operating System: Windows 10 x64
.45 problem setting buffer length under 10ms
« Reply #4 on: March 29, 2008, 21:20:13 »
Ah, i thought that it will be accepted. But shouldn't it rather be set to 10 instead of 100 if you set it to e.g. 5?
» No support, bug reports, feature requests via private messages - they will not be answered. Use the forums and the issue tracker so that everyone can benefit from your post.

Offline Snu

  • Workaholic artist
  • ***
  • Posts: 320
  • Gender: Male
    • http://www.snuq.com
  • Operating System: Windows 7 64bit
.45 problem setting buffer length under 10ms
« Reply #5 on: March 30, 2008, 09:13:23 »
this bug still exists, it still sets the buffer to 100ms.
being able to set it lower in the ini file wasnt the bug, in fact it seemed to work perfectly fine, and was a desirable feature.

Offline Relabsoluness

  • OpenMPT Developers
  • *****
  • Posts: 709
.45 problem setting buffer length under 10ms
« Reply #6 on: March 30, 2008, 21:39:22 »
Quote from: "Snu"
this bug still exists, it still sets the buffer to 100ms.
being able to set it lower in the ini file wasnt the bug, in fact it seemed to work perfectly fine, and was a desirable feature.

One reason why things seemed to work perfectly fine is that even though the setup shows that the buffer is < 10 ms, actually what is used at least in some parts of the process is 10 ms. Thus I found it better to restrict setting it below 10 ms for now.

Offline Snu

  • Workaholic artist
  • ***
  • Posts: 320
  • Gender: Male
    • http://www.snuq.com
  • Operating System: Windows 7 64bit
.45 problem setting buffer length under 10ms
« Reply #7 on: March 31, 2008, 08:58:25 »
regardless tho, the bug of it randomly setting the buffer length to 100 still remains, so this topic should be reopened