xp to vista problems

Started by anboi, June 10, 2007, 13:21:28

Previous topic - Next topic


i've just got a new laptop running vista primarily to run modplugtracker on but i'm having some issues. modplugtracker itself seems to work absolutely fine, not seen any problems in a few hours of use. i do however have a problem with a plugin - i use the vb ffx4 wrapper plugin within modplug to use directx plugins and on the new computer it opens a blank rack for all instances of it in all tracks imported from the old computer. i've deliberately set up all my directories exactly the same, the instals of all the directx plugins went in the same places and modplug and all vst plugins went in the same places. i copied the old ini file from modplug straight across and all the plugins work straight off without re-importing because all the directory references are the same. the wrapper works fine when i add plugins to a rack and it stores and remembers them ok when i'm starting a new file but it won't open anything transferred over from the old computer. so! any suggestions as to why it might be doing that? i'm not sure if it could be something daft i'm doing, a bug in modplug or a bug in vb ffx4 or what. has anyone encountered anything like this before? the only differences between systems i can think of are the operating system and the selection of directx plugins i have installed (i do have all the ones that should appear in the racks installed tho')


This problem is to be expected, since XP uses a different DirectX version than Vista does.

You can try to install DirectX 9 on Vista to hope that it'll work, but otherwise, I can only say: try to get windows XP on it, as that is probably the only way to solve it.
"Heh, maybe I should've joined the compo only because it would've meant I wouldn't have had to worry about a damn EQ or compressor for a change. " - Atlantis
"yes.. I think in this case it was wishful thinking: MPT is makng my life hard so it must be wrong" - Rewbs


i can only think of two things that might cause this...
vista might not save its directx plugins in the same way/place that xp does,
or maybe you upgraded the vst, or it has a different version for vista that doesnt properly load old config files.
either way, i agree with lp on putting xp on the laptop instead :p
personally, i cant stand vista.


cheers guys, i used the same versions but it could be directx version or vista putting dx plugins somewhere weird that's causing it i guess. i was originally planning on putting xp on but then got a laptop that's got lots of nice features that probably won't work on xp :(


so i thought i should pop in to update this after finding a few more things -
i found out i could save then import vb_ffx4 rack files succesfully so get my exact settings on the vista laptop... then found that vista crashes with modplug running after about 5 mins. damn! no idea about the cause but it could have been any of the dozens of not-designed-for-vista plugins that i had installed. i tried a few tracks before with no problems so it's likely its only the directx plugs or the wrapper that caused problems. anyway, vista was unstable for me doing basic stuff like browsing the web etc. now it's running xp and when i finish installing everything again then hopefully it'll be fine.


Yeah there seems to be no problem with modplug itself under vista, but plugins (DX and VST) that aren't compatible can be a problem.
There is only one plugin I have that has issues with vista, and that's guitar rig 2, it'll sometimes crash modplug on loading the plugin, which is annoying, but it has improved my saving of part created files!
I am Dyslexic of Borg, resemblance is fertile, your ass will be laminated.


a final update (and i hope this is of use to someone!) - i got it working! i found this out after installing all plugs etc. then finding it had the same problem as vista...
there's a file called ffx4condx.ctx in the installation directory, it seemingly retains the info on all the ffx4 instances used, what plugins they have in and all the tracks they're used in. copying it over to the new pc worked! magic. strange way for the plugin to work tho' and i'm a bit dubious about using it so heavily now, i should try xlutop chainer and things to see what they're like.