Author Topic: .47 Compatiblity Export does not work  (Read 6604 times)

Offline Saga Musix

  • OpenMPT Developers
  • *****
  • Posts: 7,013
  • aka Jojo
    • Download music, samples, VST plugins: Saga Musix Website
  • Operating System: Windows 10 x64
.47 Compatiblity Export does not work
« on: May 27, 2007, 21:20:36 »
Full Version:
OpenMPT v1.17.2.47

Description of the bug:
Hm, seems like the compatiblity export is not compatible to Impulse Tracker at all. I had problems with it during some Compos when someone complained that he couldn't open the samplepack in IT, although it was saved using compatiblity export. Luckily, IT's built-in sample-browser was able to open the module, so he could load all stuff, sample by sample. My guess is a wrong Version ID, but who knows...?
» No support, bug reports, feature requests via private messages - they will not be answered. Use the forums and the issue tracker so that everyone can benefit from your post.

Offline LPChip

  • Administrator
  • *****
  • Posts: 5,095
    • http://lpchip.nl
  • Operating System: Windows 10 Pro x64
Re: (S=O) .47 Compatiblity Export does not work
« Reply #1 on: May 27, 2007, 21:48:48 »
Quote from: "Jojo"
Full Version:
OpenMPT v1.17.2.47

Description of the bug:
Hm, seems like the compatiblity export is not compatible to Impulse Tracker at all. I had problems with it during some Compos when someone complained that he couldn't open the samplepack in IT, although it was saved using compatiblity export. Luckily, IT's built-in sample-browser was able to open the module, so he could load all stuff, sample by sample. My guess is a wrong Version ID, but who knows...?


It is possible that stereo samples were used? IT had only support for mono samples.
"Heh, maybe I should've joined the compo only because it would've meant I wouldn't have had to worry about a damn EQ or compressor for a change. " - Atlantis
"yes.. I think in this case it was wishful thinking: MPT is makng my life hard so it must be wrong" - Rewbs

Offline rewbs

  • OpenMPT Developers
  • *****
  • Posts: 578
.47 Compatiblity Export does not work
« Reply #2 on: May 27, 2007, 21:48:58 »
Can you provide the problematic file?

Offline Saga Musix

  • OpenMPT Developers
  • *****
  • Posts: 7,013
  • aka Jojo
    • Download music, samples, VST plugins: Saga Musix Website
  • Operating System: Windows 10 x64
Re: (S=O) .47 Compatiblity Export does not work
« Reply #3 on: May 27, 2007, 21:53:27 »
Quote from: "LPChip"
It is possible that stereo samples were used? IT had only support for mono samples.

for maximum compatiblity, i use 8bit mono samples only ;) only in compos for sure :lol:

testcase (it works with virtually every file, so i just made a new, small one): (link removed)
the song title is shown correctly in IT, but file format is "Impulse Tracker ?.??" - i guess it got a problem with the file version then?

by the way, i had no problem with Modplug 1.16 and IT, even if i used the "hacks".
» No support, bug reports, feature requests via private messages - they will not be answered. Use the forums and the issue tracker so that everyone can benefit from your post.

Offline rewbs

  • OpenMPT Developers
  • *****
  • Posts: 578
.47 Compatiblity Export does not work
« Reply #4 on: May 27, 2007, 22:27:53 »
You're right, the .it version numbers are all wrong. Will fix.

Offline Saga Musix

  • OpenMPT Developers
  • *****
  • Posts: 7,013
  • aka Jojo
    • Download music, samples, VST plugins: Saga Musix Website
  • Operating System: Windows 10 x64
.47 Compatiblity Export does not work
« Reply #5 on: October 11, 2007, 23:10:21 »
Any hope that this will be fixed soon? It's quite bad to have incompatible sample packs at compos... :\ I mean, that can't be much work, can it? Just changing a version variable...
» No support, bug reports, feature requests via private messages - they will not be answered. Use the forums and the issue tracker so that everyone can benefit from your post.

Offline Relabsoluness

  • OpenMPT Developers
  • *****
  • Posts: 709
.47 Compatiblity Export does not work
« Reply #6 on: October 13, 2007, 19:13:29 »
Quote from: "Jojo"
Any hope that this will be fixed soon? It's quite bad to have incompatible sample packs at compos... :\ I mean, that can't be much work, can it? Just changing a version variable...

I would imagine that a possible fix will be in the next build, but I don't know when it is to appear.


Offline Saga Musix

  • OpenMPT Developers
  • *****
  • Posts: 7,013
  • aka Jojo
    • Download music, samples, VST plugins: Saga Musix Website
  • Operating System: Windows 10 x64
.47 Compatiblity Export does not work
« Reply #8 on: November 01, 2007, 16:11:57 »
Files can be loaded, but I still can't use you project tree (no audio, openmpt crashes ;) )
» No support, bug reports, feature requests via private messages - they will not be answered. Use the forums and the issue tracker so that everyone can benefit from your post.

Offline Saga Musix

  • OpenMPT Developers
  • *****
  • Posts: 7,013
  • aka Jojo
    • Download music, samples, VST plugins: Saga Musix Website
  • Operating System: Windows 10 x64
.47 Compatiblity Export does not work
« Reply #9 on: December 01, 2007, 16:26:19 »
Fixed in .49 test build.
» No support, bug reports, feature requests via private messages - they will not be answered. Use the forums and the issue tracker so that everyone can benefit from your post.