Author Topic: .46 Mix Level set to RC3 for old modules  (Read 7943 times)

Offline Saga Musix

  • OpenMPT Developers
  • *****
  • Posts: 6,680
  • aka Jojo
    • Download music, samples, VST plugins: Saga Musix Website
  • Operating System: Windows 10 x64
.46 Mix Level set to RC3 for old modules
« on: May 09, 2007, 13:38:48 »
Full Version:
OpenMPT v1.17.2.46

Description of the bug:
Okay, at least i consider that as a bug.
The mix level is set to RC3 for every module that doesn't have an own mix level set. Old modules however tend to overdrive with that setting easily. And you can't change the mix settings for MOD files at all...
» No support, bug reports, feature requests via private messages - they will not be answered. Use the forums and the issue tracker so that everyone can benefit from your post.

Offline rewbs

  • OpenMPT Developers
  • *****
  • Posts: 578
.46 Mix Level set to RC3 for old modules
« Reply #1 on: May 09, 2007, 17:48:24 »
d'oh sorry - fix coming soon.

Offline Saga Musix

  • OpenMPT Developers
  • *****
  • Posts: 6,680
  • aka Jojo
    • Download music, samples, VST plugins: Saga Musix Website
  • Operating System: Windows 10 x64
.46 Mix Level set to RC3 for old modules
« Reply #2 on: May 09, 2007, 19:02:00 »
thanks, that would be great :) it really is not possible to listen to modules that were not saved with OpenMPT :D
» No support, bug reports, feature requests via private messages - they will not be answered. Use the forums and the issue tracker so that everyone can benefit from your post.

Offline rewbs

  • OpenMPT Developers
  • *****
  • Posts: 578
.46 Mix Level set to RC3 for old modules
« Reply #3 on: May 13, 2007, 13:46:03 »
Please confirm this is fixed in 1.17.02.47

Offline Saga Musix

  • OpenMPT Developers
  • *****
  • Posts: 6,680
  • aka Jojo
    • Download music, samples, VST plugins: Saga Musix Website
  • Operating System: Windows 10 x64
.46 Mix Level set to RC3 for old modules
« Reply #4 on: May 13, 2007, 15:54:42 »
It's fixed, but i have to lower the preamp value to almost nothing, the standard 33% that worked for years are still too loud.
» No support, bug reports, feature requests via private messages - they will not be answered. Use the forums and the issue tracker so that everyone can benefit from your post.

Offline LPChip

  • Administrator
  • *****
  • Posts: 5,054
    • http://lpchip.nl
  • Operating System: Windows 10 Pro x64
.46 Mix Level set to RC3 for old modules
« Reply #5 on: May 13, 2007, 20:44:56 »
I guess its not fixed then?

I'll set the status to Open again. Rewbs, if you think this is incorrect, feel free to change it. :)
"Heh, maybe I should've joined the compo only because it would've meant I wouldn't have had to worry about a damn EQ or compressor for a change. " - Atlantis
"yes.. I think in this case it was wishful thinking: MPT is makng my life hard so it must be wrong" - Rewbs

Offline Saga Musix

  • OpenMPT Developers
  • *****
  • Posts: 6,680
  • aka Jojo
    • Download music, samples, VST plugins: Saga Musix Website
  • Operating System: Windows 10 x64
.46 Mix Level set to RC3 for old modules
« Reply #6 on: May 14, 2007, 12:40:50 »
right. the RC2 behaviour is the way it behaved for years.
» No support, bug reports, feature requests via private messages - they will not be answered. Use the forums and the issue tracker so that everyone can benefit from your post.

Offline rewbs

  • OpenMPT Developers
  • *****
  • Posts: 578
.46 Mix Level set to RC3 for old modules
« Reply #7 on: May 27, 2007, 16:45:46 »
Quote from: "Jojo"
i have to lower the preamp value to almost nothing, the standard 33% that worked for years are still too loud.


Hmm I can't reproduce this. If I load a track with "original" mix levels and play it with 1.17.02.47 and the pre-open source MPT (1.16), I get about the same output levels in both versions with preamp at 33%.  Could you provide a testcase or give more details?

Offline Saga Musix

  • OpenMPT Developers
  • *****
  • Posts: 6,680
  • aka Jojo
    • Download music, samples, VST plugins: Saga Musix Website
  • Operating System: Windows 10 x64
.46 Mix Level set to RC3 for old modules
« Reply #8 on: May 27, 2007, 19:47:51 »
it works with every module file i got. In openMPT, the preamp slider is at the second line from bottom (VERY LOW). i get the same volume in Modplug 1.16 when i move the slider to ~50%...
» No support, bug reports, feature requests via private messages - they will not be answered. Use the forums and the issue tracker so that everyone can benefit from your post.

Offline rewbs

  • OpenMPT Developers
  • *****
  • Posts: 578
.46 Mix Level set to RC3 for old modules
« Reply #9 on: May 27, 2007, 20:30:31 »
Quote from: "Jojo"
it works with every module file i got. In openMPT, the preamp slider is at the second line from bottom (VERY LOW). i get the same volume in Modplug 1.16 when i move the slider to ~50%...


I'd appreciate if you could send me a testcase just to confirm we are looking at exactly the same data. Meanwhile, if anyone else can reproduce, let me know..

Offline Saga Musix

  • OpenMPT Developers
  • *****
  • Posts: 6,680
  • aka Jojo
    • Download music, samples, VST plugins: Saga Musix Website
  • Operating System: Windows 10 x64
.46 Mix Level set to RC3 for old modules
« Reply #10 on: May 27, 2007, 21:05:54 »
okay, I uploaded the smallest mod i could find :)
(link removed, no longer neccesary)
» No support, bug reports, feature requests via private messages - they will not be answered. Use the forums and the issue tracker so that everyone can benefit from your post.

Offline Saga Musix

  • OpenMPT Developers
  • *****
  • Posts: 6,680
  • aka Jojo
    • Download music, samples, VST plugins: Saga Musix Website
  • Operating System: Windows 10 x64
.46 Mix Level set to RC3 for old modules
« Reply #11 on: May 27, 2007, 21:25:40 »
i think it's fixed in .48
» No support, bug reports, feature requests via private messages - they will not be answered. Use the forums and the issue tracker so that everyone can benefit from your post.

Offline LPChip

  • Administrator
  • *****
  • Posts: 5,054
    • http://lpchip.nl
  • Operating System: Windows 10 Pro x64
.46 Mix Level set to RC3 for old modules
« Reply #12 on: May 27, 2007, 21:46:26 »
Quote from: "Jojo"
i think it's fixed in .48


Okay :)

Closing this one. If it seems that its not fixed, then feel free to post so it can be reopened again. :)
"Heh, maybe I should've joined the compo only because it would've meant I wouldn't have had to worry about a damn EQ or compressor for a change. " - Atlantis
"yes.. I think in this case it was wishful thinking: MPT is makng my life hard so it must be wrong" - Rewbs

Offline Saga Musix

  • OpenMPT Developers
  • *****
  • Posts: 6,680
  • aka Jojo
    • Download music, samples, VST plugins: Saga Musix Website
  • Operating System: Windows 10 x64
.46 Mix Level set to RC3 for old modules
« Reply #13 on: August 25, 2007, 20:46:18 »
hm, after listening to some old modules, i found the current behaviour still irritating... the global volume of a standard MOD is 128 (can't be changed) which is okay. but most modules tend to overdrive, they're always in the red part of the VU meters. It sounds okay at a global volume of 64 (which won't be stored). So i would suppose that the "original" mix level will be half as loud to 2/3 of the current volume.
» No support, bug reports, feature requests via private messages - they will not be answered. Use the forums and the issue tracker so that everyone can benefit from your post.

Offline LPChip

  • Administrator
  • *****
  • Posts: 5,054
    • http://lpchip.nl
  • Operating System: Windows 10 Pro x64
.46 Mix Level set to RC3 for old modules
« Reply #14 on: August 26, 2007, 10:23:07 »
I've reopened the bug for you.

Maybe we should just use the old mix settings? Not RC1, RC2 nor RC3?

Or ofcource, we can set global volume to 64 for modules. :)

I always use a global volume of 64 when I work with RC3 because everything above is just way too hard.
"Heh, maybe I should've joined the compo only because it would've meant I wouldn't have had to worry about a damn EQ or compressor for a change. " - Atlantis
"yes.. I think in this case it was wishful thinking: MPT is makng my life hard so it must be wrong" - Rewbs