Author Topic: Soundfont troubles :(  (Read 14443 times)

Offline Kosztya

  • Active artist
  • *
  • Posts: 36
    • http://www.kosztya.uw.hu
Soundfont troubles :(
« Reply #15 on: August 13, 2006, 21:38:15 »
Thank you, but it was downloaded by me, but after it there were no change!!!

Offline Kosztya

  • Active artist
  • *
  • Posts: 36
    • http://www.kosztya.uw.hu
Soundfont troubles :(
« Reply #16 on: August 13, 2006, 22:02:07 »
YES! YES! YES!!!!
VERY YES!!!

My brain was too slow in this evening (My mother used to say)!
I have found the update, and downloaded it!
Now I see the MIDI CC!

Thank You very much my friends, YOU ARE THE GODs!

Tomorrow I will begin to work with it, if I have question I will come back.
Good night!

Offline Kosztya

  • Active artist
  • *
  • Posts: 36
    • http://www.kosztya.uw.hu
Soundfont troubles :(
« Reply #17 on: August 14, 2006, 18:49:12 »
Hy! I'm again.
Yesterday I was very happy when (after an update) I found the "MIDI CC" under the "Zxx macros".

But the problem is the same...  :cry:
I do everithing on that way as speed-focus' tutorial shows, but no plugins which works.

- I changed more plugins...
- I selected effects (under the "MIDI CC")...
But there is no any reaction of the plugins.

What can be another problem with it?

Offline rewbs

  • OpenMPT Developers
  • *****
  • Posts: 578
Soundfont troubles :(
« Reply #18 on: August 14, 2006, 19:34:24 »
Is the plugin active on the channel on which you are tweaking the param? The plugin must either be assigned directly to the channel or to an instrument that is playing on the channel.

If that's not it, please make an example song available and we'll be able to see where the problem is.

Offline Kosztya

  • Active artist
  • *
  • Posts: 36
    • http://www.kosztya.uw.hu
Soundfont troubles :(
« Reply #19 on: August 14, 2006, 20:13:20 »
Rewbs, I don't understand well, what you ask.
But I describes how I load a plugin (the problem can be here).

General Menu:
1. Under the "Effect Plugins" I select the "Slayer2" guitar plugin, and put it in "FX1" (FX1: Slayer2)

2. Than in the scrolling "Effect" menu of the first channel I choose this plugin as well.

3. Now, if I click on the "Edit" menu I can see the picture of my plugin, but it doesn't give voice.

4. Now, I go to the "Instrument" menu

5. I click on "New Instrument" button

6. Under the "Plugin/Midi" text I sign "FX1 Slayer2"

7. I go into the "Patterns" menu, and under the "Main instrument" text I sign this plugin as well.

So in this way I can hear its voice, and I can write it into the channel, but only the effects don't want to work.

I have some patterns in which I wanted to use effect. If you have an e-mail address (or any other) I send it!
I would be very happy to find the key of my probem...

Offline LPChip

  • Administrator
  • *****
  • Posts: 5,135
    • http://lpchip.nl
  • Operating System: Windows 10 Pro x64
Soundfont troubles :(
« Reply #20 on: August 14, 2006, 20:37:11 »
In order to tweak your parameters first do an SFx (same as the one you tweak in the Zxx menu) and then put the Zxx in Channel 1 where you loaded slayer also. Should work!
"Heh, maybe I should've joined the compo only because it would've meant I wouldn't have had to worry about a damn EQ or compressor for a change. " - Atlantis
"yes.. I think in this case it was wishful thinking: MPT is makng my life hard so it must be wrong" - Rewbs

Offline Kosztya

  • Active artist
  • *
  • Posts: 36
    • http://www.kosztya.uw.hu
Soundfont troubles :(
« Reply #21 on: August 14, 2006, 20:44:58 »
Quote from: "LPChip"
In order to tweak your parameters first do an SFx (same as the one you tweak in the Zxx menu) and then put the Zxx in Channel 1 where you loaded slayer also. Should work!


Okay, Tomorrow I come back, and try it.

If it won't work I send you a song, to controll what is the problem! Please give me an address. (Or can I send it to your e-mail address?)

Offline rewbs

  • OpenMPT Developers
  • *****
  • Posts: 578
Soundfont troubles :(
« Reply #22 on: August 14, 2006, 22:24:54 »
Quote
I have some patterns in which I wanted to use effect.

So do you want to apply effects to your plugin, or tweak the plugin parameters? Your goal is not clear to me.

Quote from: "Kosztya"
give me an address. (Or can I send it to your e-mail address?)

Yes you can email it to rewbs at soal dot org.

Offline Kosztya

  • Active artist
  • *
  • Posts: 36
    • http://www.kosztya.uw.hu
Soundfont troubles :(
« Reply #23 on: August 15, 2006, 20:02:15 »
I'am here again.
Sorry, but this day was very long. (Here 9:45pm)

Quote
Yes you can email it to rewbs at soal dot org.

Rewbs: What kind of e-mail address is this?

If you don't want to write it into an opened forum, please write me a sort letter (this will include your address).
My address: kosztya19@externet.hu

When your letter arrives I will answer to you.
My (re)mail will includes:
- a short song (one pattern) with the "Zxx" codes
- the necessary plugins (a drum plugin, and the Slayer2 one)
These files won't be more than 4Mb.
Subject (title) will be: OMPT (So you will know, that is not a a spam, or a virus infected mail).

A lot of thanks for your helping!!!

Offline rewbs

  • OpenMPT Developers
  • *****
  • Posts: 578
Soundfont troubles :(
« Reply #24 on: August 16, 2006, 15:22:49 »
I sent an email to Kosztya.

Offline Kosztya

  • Active artist
  • *
  • Posts: 36
    • http://www.kosztya.uw.hu
Soundfont troubles :(
« Reply #25 on: August 16, 2006, 17:56:46 »
Quote from: "rewbs"
I sent an email to Kosztya.


I've got it, And I've sent my mail...

Offline rewbs

  • OpenMPT Developers
  • *****
  • Posts: 578
Soundfont troubles :(
« Reply #26 on: August 16, 2006, 19:26:22 »
Hi,

The problem is very simple:
. You have correctly set the song up so that Zxx sends MIDI CC10 value xx to Slayer2.
. However, as far as I can see, Slayer2 does not understand MIDI CC10. How did you expect Slayer2 to respond to MIDI CC10, and why did you expect that?
. If you set up SF1 to control any of Slayer2's many parameters, it will work fine.

Based on previous posts, I guess you want to control panning.
I believe Slayer2 has no panning parameter. Therefore, you must route Slayer2 through another plugin which does have a panning parameter.
I will send you your song back with this modification.

In general, when reporting a problem, I think it is good to describe precisely your objectives first (for example "I want to control the panning on Slayer2"). You will get better help that way.

Offline Kosztya

  • Active artist
  • *
  • Posts: 36
    • http://www.kosztya.uw.hu
Soundfont troubles :(
« Reply #27 on: August 16, 2006, 20:14:37 »
Thank You Very Much Rewbs!

In this way, the panning effect works correctly!!!

I will translate your latest reply correctly (there are some unknown words for me  :oops: ) and I will begin to continue my music-maker activity -WITH PLUGINS!!!

I'm very happy now!!!