Export as MIDI - Octaves follow the instrument Sample Map, not the actual notes?

Started by NorrinRadd22, January 24, 2023, 08:52:36

Previous topic - Next topic

NorrinRadd22

I am exporting a project so that I can open the midi in Cubase after. What's happening though is that my midi file appears to follow the octave information from the Sample Map of my instruments, rather than the notes I am entering in the Pattern tab.

My instruments consist of one sample per octave, and if I were to create a pattern that goes from the lowest to the highest note, export that midi, then open it in Cubase, it ends up looking like the image attached. Instead of a solid climb up through every octave, it seems to just follow whatever octave would be played according to the samples in my Sample Map in the Instrument Tab. This seems super counter intuitive to me, at least for my use case.

I want to use that midi information to do things in Cubase, such as run it through synths instead of samples, but having to manually go in and try to correct every note to fit in the right octave it is heard in the Modplug project is a deal breaker. I want to also mix the project in Cubase, so no, I am not interested in opening any synths inside of Modplug itself.

Anyone know if a way to fix this?


Saga Musix

The code that handles MIDI export has no knowledge of pattern notes, it only receives the notes from the sample map. Since there is no root note information associated with samples at the moment, MIDI export cannot know if the note map is set up this way because you have a peculiar instrument setup (e.g. a drum kit) or because all your samples have different root notes.
Adding root note information is at least a goal for the MPTM format eventually, but until we get there, there's two workarounds:

- If the note map can be mapped cleanly to a linear map, the "Transepose Samples / Reset Map" context menu entry is available. This will transpose all sampled associated with the instrument up or down as needed, and both the module itself* as well as the exported MIDI file will sound as intended in most cases. *The module may sound different if it used any Tone Portamento effects between notes belonging to different samples.
- If that option is not available, you can still use "Reset Note Mapping" from the same context menu temporarily just for MIDI export.
» No support, bug reports, feature requests via private messages - they will not be answered. Use the forums and the issue tracker so that everyone can benefit from your post.

NorrinRadd22

You glorious son of a gun, you did it! That was exactly the work around I needed. My export is smooth now! Thank you so much! I have a huge project hinging on this, and you may have just saved my bacon big time! :)