Author Topic: How to stop clicking on IT modules?  (Read 308 times)

Offline dexbasson

  • Shy artist
  • Posts: 4
How to stop clicking on IT modules?
« on: April 02, 2022, 17:10:37 »
My modules sound fine on OpenMPT but when i try playing them on xmplay it has a lot of clicking unless i use sensitive ramping.
but sensitive ramping kills a lot of the attack and i've tried other IT modules made on OpenMPT (not made by me) and they sound just fine.

Am i missing something? i can work around it using tone portamento everywhere but its not really ideal bcuz the first note still clicks and it sound weird when used on sinewaves.

I also tried fiddling with the compatibility options but got nothing outta that.

Offline Saga Musix

  • OpenMPT Developers
  • *****
  • Posts: 7,506
  • aka Jojo
    • Download music, samples, VST plugins: Saga Musix Website
  • Operating System: Windows 10 x64
Re: How to stop clicking on IT modules?
« Reply #1 on: April 02, 2022, 18:05:40 »
Sensitive ramping is generally the best option in XMPlay. Simple waveforms like sines or squares in particular are very suspectible to clicks just due to the nature of their waveform (in greatly simplified terms, stoping a sample creates an impulse when it goes from its current value to complete silence, and this impulse contains all frequencies at once, while a pure sine sinewave is exactly one frequency). Generally it is not defined how much ramping an IT replayer should apply to samples, so the amount of clicks you get will differ between various programs in general.

The best workaround might be to set the New Note Action for the most problematic instruments to Note Fade and use a very high fadeout value for that instrument (e.g. 8192, the highest possible value). This way you avoid relying on how the player implements note cuts and how much ramping it applies, because it will be forced to apply a soft fadeout instead.
ยป No support, bug reports, feature requests via private messages - they will not be answered. Use the forums and the issue tracker so that everyone can benefit from your post.

Offline dexbasson

  • Shy artist
  • Posts: 4
Re: How to stop clicking on IT modules?
« Reply #2 on: April 02, 2022, 21:48:21 »
Nice!!

Using note fade really works on minimizing the clicking, thanks a lot!