Author Topic: Running OpenMPT on historic systems  (Read 695 times)

Offline manx

  • OpenMPT Developers
  • *****
  • Posts: 226
Running OpenMPT on historic systems
« on: July 04, 2019, 10:15:19 »
Running OpenMPT on historic systems

These tables might be useful if you want to run OpenMPT on old systems.

If you found a bug in the current version (marked green or orange), or have other issues that prevent you from upgrading, please don't just go back to using an old version.
Instead, please report the bug so that we can actually fix it.


Any version of OpenMPT that is marked red or purple is not supported any more by the OpenMPT team. We will not fix any bugs in unsupported OpenMPT versions.

Any version of Windows that is marked red or purple is not supported any more by Microsoft, and should not be used with any connection to an untrusted network, especially not the internet.

The information presented here is based on historic documentation and in some cases on guesses only. It in particular has not been verified on actual systems.

Minimum system requirements for OpenMPT versions

OpenMPT
minimum
Windows
Versions
minimum
Wine
Version
minimum
CPU
features
minimum CPUs
OpenMPT 1.28
OpenMPT 1.28 download
Windows 7
1.8
686 + SSE2
686+SSE2: Intel Pentium 4, AMD Athlon 64, VIA C7, Transmeta Efficeon
amd64: Intel Pentium D, AMD Athlon 64, VIA Nano, Zhaoxin Kaixian ZX-A
OpenMPT 1.28-old
OpenMPT 1.28 download
Windows XP
1.8
586 + CPUID
586+CPUID: Intel Pentium, AMD K5, Cyrix 6x86MX, NSC Geode GX1, VIA Cyrix III, Transmeta Crusoe, SiS 55x, RDC IAD 100
amd64: Intel Pentium D, AMD Athlon 64, VIA Nano, Zhaoxin Kaixian ZX-A
OpenMPT 1.27
OpenMPT 1.27.11 (x86 installer)
OpenMPT 1.27.11 (amd64 installer)
OpenMPT 1.27.11 (x86 zip)
OpenMPT 1.27.11 (amd64 zip)
Windows 7
1.8
686 + SSE2
686+SSE2: Intel Pentium 4, AMD Athlon 64, VIA C7, Transmeta Efficeon
amd64: Intel Pentium D, AMD Athlon 64, VIA Nano, Zhaoxin Kaixian ZX-A
OpenMPT 1.27-old
OpenMPT 1.27.11-old (x86 installer)
OpenMPT 1.27.11-old (amd64 installer)
OpenMPT 1.27.11-old (x86 zip)
OpenMPT 1.27.11-old (amd64 zip)
Windows XP
1.6
586 + CPUID
586+CPUID: Intel Pentium, AMD K5, Cyrix 6x86MX, NSC Geode GX1, VIA Cyrix III, Transmeta Crusoe, SiS 55x, RDC IAD 100
amd64: Intel Pentium D, AMD Athlon 64, VIA Nano, Zhaoxin Kaixian ZX-A
OpenMPT 1.25..1.26
OpenMPT 1.26.14 (x86 installer)
OpenMPT 1.26.14 (amd64 installer)
OpenMPT 1.26.14 (x86 zip)
OpenMPT 1.26.14 (amd64 zip)
Windows 7
1.4
686 + SSE2
686+SSE2: Intel Pentium 4, AMD Athlon 64, VIA C7, Transmeta Efficeon
amd64: Intel Pentium D, AMD Athlon 64, VIA Nano, Zhaoxin Kaixian ZX-A
OpenMPT 1.25-old..1.26-old
OpenMPT 1.26.14-old (x86 installer)
OpenMPT 1.26.14-old (x86 zip)
Windows 2000
Windows 98 SE + KEx
1.0
586
586: Intel Pentium, AMD K5, Cyrix 6x86, Rise mP6, IDT WinChip C6
586+CPUID: NSC Geode GX1, VIA Cyrix III, Transmeta Crusoe, SiS 55x, RDC IAD 100
amd64: Intel Pentium D, AMD Athlon 64, VIA Nano, Zhaoxin Kaixian ZX-A
OpenMPT 1.19..1.24
OpenMPT 1.24.04 (x86 installer)
OpenMPT 1.24.04 (amd64 installer)
OpenMPT 1.24.04 (x86 zip)
OpenMPT 1.24.04 (amd64 zip)
Windows 2000
Windows 98 SE + KEx
1.0
586
586: Intel Pentium, AMD K5, Cyrix 6x86, Rise mP6, IDT WinChip C6
586+CPUID: NSC Geode GX1, VIA Cyrix III, Transmeta Crusoe, SiS 55x, RDC IAD 100
amd64: Intel Pentium D, AMD Athlon 64, VIA Nano,  Zhaoxin Kaixian ZX-A
OpenMPT 1.17..1.18
OpenMPT 1.18.03 (x86 installer)
OpenMPT 1.18.03 (x86 zip)
Windows 2000
Windows 98 SE
0.x
486DX
486: Intel 80486DX, AMD Am486 DX, Cyrix Cx486DX, NexGen Nx586-PF, DM&P Vortex86DX
586: Rise mP6, IDT WinChip C6
586+CPUID: NSC Geode GX1, VIA Cyrix III, Transmeta Crusoe, SiS 55x, RDC IAD 100
amd64: Intel Pentium D, AMD Athlon 64, VIA Nano, Zhaoxin Kaixian ZX-A
ModPlug Tracker 1.00..1.16
ModPlug Tracker 1.16.207 (x86 zip)
Windows NT4
Windows 95
0.x
486DX
486: Intel 80486DX, AMD Am486 DX, Cyrix Cx486DX, NexGen Nx586-PF, DM&P Vortex86DX
586: Rise mP6, IDT WinChip C6
586+CPUID: NSC Geode GX1, VIA Cyrix III, Transmeta Crusoe, SiS 55x, RDC IAD 100
amd64: Intel Pentium D, AMD Athlon 64, VIA Nano, Zhaoxin Kaixian ZX-A
  • green: supported OpenMPT version
  • orange: supported OpenMPT version for older systems
  • red: unsupported OpenMPT version
  • purple: unsupported OpenMPT version, there are newer versions with the same minimum system requirements available

Latest OpenMPT version that runs on a given Operating System and CPU configuration

Windows
486DX
586
586+CPUID
686+SSE2
amd64
Windows
Windows 95
1.16
1.16
1.16
1.16
-
Windows 95
Windows 98
1.16
1.16
1.16
1.16
-
Windows 98
Windows 98 SE
1.18
1.18
1.18
1.18
-
Windows 98 SE
Windows ME
-
1.18
1.18
1.18
-
Windows ME
Windows 98 SE + KEx
1.18
1.26-old
1.26-old
1.26-old
-
Windows 98 SE + KEx
Windows ME + KEx
-
1.26-old
1.26-old
1.26-old
-
Windows ME + KEx
Windows
486DX
586
586+CPUID
686+SSE2
amd64
Windows
Wine 0.x.x
1.18
1.18
1.18
1.18
-
Wine 0.x.x
Wine 1.0.x
1.18
1.26-old
1.26-old
1.26-old
-
Wine 1.0.x
Wine 1.2.x
1.18
1.26-old
1.26-old
1.26-old
-
Wine 1.2.x
Wine 1.4.x
1.18
1.26-old
1.26-old
1.26
-
Wine 1.4.x
Wine 1.6.x
-
-
1.27-old
1.27-old
1.27-old
Wine 1.6.x
Wine 1.8.x
-
-
1.28-old
1.28
1.28
Wine 1.8.x
Wine 2.0.x
-
-
1.28-old
1.28
1.28
Wine 2.0.x
Wine 3.0.x
-
-
1.28-old
1.28
1.28
Wine 3.0.x
Wine 4.0.x
-
-
1.28-old
1.28
1.28
Wine 4.0.x
Windows
486DX
586
586+CPUID
686+SSE2
amd64
Windows
Windows NT4
1.16
1.16
1.16
1.16
-
Windows NT4
Windows 2000
-
-
1.26-old
1.26-old
-
Windows 2000
Windows XP
-
-
1.28-old
1.28-old
1.28-old
Windows XP
Windows Vista
-
-
1.28-old
1.28-old
1.28-old
Windows Vista
Windows 7
-
-
-
1.28
1.28
Windows 7
Windows 8
-
-
-
1.28
1.28
Windows 8
Windows 8.1
-
-
-
1.28
1.28
Windows 8.1
Windows 10
-
-
-
1.28
1.28
Windows 10
Windows
486DX
586
586+CPUID
686+SSE2
amd64
Windows
« Last Edit: July 04, 2019, 18:38:04 by manx »