Author Topic: Winamp fails to load in_openmpt [Solved]  (Read 718 times)

Offline xoft

  • Shy artist
  • Posts: 2
  • Operating System: Windows 8.1N Pro
Winamp fails to load in_openmpt [Solved]
« on: July 22, 2019, 19:13:32 »
Hello,

I've just tried to use the in_openmpt.dll plugin for Winamp, and for unknown reason it fails to load. Is the plugin actually used by someone, or is it long-dead? Am I the only one with the problem, or do other people see similar behavior?

Unfortunately I can't seem to find any debug info from Winamp, so there's only very little info I can add to this report. I tried loading Winamp in MSVC, it doesn't output any debug information (OutputDebugString()), but at least MSVC shows module loads and unloads, I get this:

'winamp.exe' (Win32): Loaded 'C:\Program Files (x86)\Winamp\Plugins\in_openmpt.dll'. Cannot find or open the PDB file.
'winamp.exe' (Win32): Loaded 'C:\Windows\SysWOW64\oleacc.dll'. Symbols loaded.
'winamp.exe' (Win32): Unloaded 'C:\Program Files (x86)\Winamp\Plugins\in_openmpt.dll'
'winamp.exe' (Win32): Unloaded 'C:\Windows\SysWOW64\oleacc.dll'

So it seems it loads the plugin, decides for some reason it doesn't like it, and unloads it again.

I'm on Windows 8.1N Pro 64-bit, Winamp 5.621 (I know there's a newer one, but "if it ain't broke, don't fix it").

I'll try compiling in_openmpt.dll for myself to see what's going on, I just want to know if I missed something obvious.
« Last Edit: July 22, 2019, 19:39:11 by xoft »

Offline xoft

  • Shy artist
  • Posts: 2
  • Operating System: Windows 8.1N Pro
Re: Winamp fails to load in_openmpt
« Reply #1 on: July 22, 2019, 19:38:30 »
Ah, found this issue: https://bugs.openmpt.org/view.php?id=1137
And it provided a solution, although inverse. The documentation says "place both in_openmpt.dll and openmpt-mpg123.dll to the Winamp's Plugins folder". For me, this was wrong, placing openmpt-mpg123.dll next to winamp.exe fixed the problem, the plugin now loads correctly.
« Last Edit: July 22, 2019, 19:42:30 by xoft »

Offline manx

  • OpenMPT Developers
  • *****
  • Posts: 237
Re: Winamp fails to load in_openmpt
« Reply #2 on: July 22, 2019, 19:45:57 »
Thanks for the report.
Looks like the documentation was wrong for 0.4 and 0.5. openmpt-mpg123.dll must be placed into the Winamp folder (not the Winamp/Plugins folder as claimed by documentation), in addition to in_openmpt.dll in the Winamp/Plugins directory.

So, yes, probably very few users of in_openmpt.dll. It is not considered dead (yet) though. However, I guess most users use either XMPlay with xmp-openmpt, or foobar2000 with foo_openmpt or foo_openmpt54 (later one is recommended). Also note that newer Winamp flavours already ship either: a rather old and modified in_openmpt.dll (renamed to in_mod.dll) in Winamp 5.8, or a modern and modified in_openmpt.dll (renamed in in_mod.dll) in WACUP.

As a matter of fact, probably as soon as verbatim Winamp (as opposed to WACUP) also starts shipping modern in_openmpt (and updates it regularly), there would probably no reason for us to continue in_openmpt. Until then, it continues to exist, albeit with close to no development effort (as we would rather prefer the Winamp and/or WACUP developers to take over maintainership).

Documentation fixed as of https://source.openmpt.org/browse/openmpt/?op=revision&rev=11818 and https://source.openmpt.org/browse/openmpt/?op=revision&rev=11819 .
Works for me with Winamp 5.666 on Windows 8.1 Pro, and Winamp 5.666 on Windows XP Pro.


Offline Midori Mizuno

  • Inspired artist
  • **
  • Posts: 57
  • Gender: Female
  • I write IT music once in a blue moon ^~^
    • BotB profile
  • Operating System: Windows 8.1 x64 and XP SP3 x86
Re: Winamp fails to load in_openmpt [Solved]
« Reply #3 on: July 23, 2019, 12:29:08 »
I actually use the plugin in every one of these 3 players (yes i keep them all arouind, Winamp and XMPlay are for fast previews, because Foobar is too playlist-oriented for that to be convenient) and i never had issues with the Winamp one (FWIW i use it with WA v2.91)