Author Topic: Future of foo_openmpt  (Read 593 times)

Offline manx

  • OpenMPT Developers
  • *****
  • Posts: 204
Future of foo_openmpt
« on: January 12, 2019, 11:21:59 »
tl;dr:
foo_openmpt is discontinued as of libopenmpt 0.5. Please use foo_openmpt54 instead.

The libopenmpt maintainers have come to the conclusion that we will not have the required time available to continue developing and improving the foobar2000 libopenmpt component foo_openmpt. Thus, we have decided to discontinue its development with the libopenmpt 0.5 line. We recommend users to switch to Kode54's fork foo_openmpt54. Kode54 has more experience with foobar2000 than any of the libopenmpt developers have, and is thus better qualified to provide an appropriate component implementation. As of now, foo_openmpt54 already has more features than foo_openmpt probably would ever be able to get due to time constraints. foo_openmpt 0.4 (our current stable version) will continue to exist and receive updates for as long as libopenmpt 0.4 is maintained (due to our stable version guarantees). However, users are already advised to switch to foo_openmpt54 even now.

Regards,
manx and Saga Musix