Author Topic: vst controls lost on export  (Read 812 times)

Offline Bogzla

  • Active artist
  • *
  • Posts: 10
  • Operating System: Windows 7
vst controls lost on export
« on: August 28, 2018, 04:34:24 »
So I was wondering if others have encountered this before reporting as a bug..
Only happened on one specific plugin so far (that I have noticed) - The controls (in this case using the built in LFO, but also happens with PC commands) work as expected during playback, but when it comes to exporting the file it's as though they are ignored completely..
This occurs whether exporting lossless or lossy..
v1.27.09.00
attached example module & export, the dll is here:
http://hssd.hu/vst/hotelsinusreesebasslinebig.zip

Offline Saga Musix

  • OpenMPT Developers
  • *****
  • Posts: 6,491
  • aka Jojo
    • Download music, samples, VST plugins: Saga Musix Website
  • Operating System: Windows 7 x64
Re: vst controls lost on export
« Reply #1 on: August 28, 2018, 12:27:20 »
Yes, this is a problem with some broken SynthMaker or SynthEdit plugins, and there is a work-around: https://wiki.openmpt.org/Manual:_Known_Issues#SynthMaker_plugins
Best would be to just not use such an old buggy plugin.
ยป No support, bug reports, feature requests via private messages - they will not be answered. Use the forums and the issue tracker so that everyone can benefit from your post.

Offline Bogzla

  • Active artist
  • *
  • Posts: 10
  • Operating System: Windows 7
Re: vst controls lost on export
« Reply #2 on: August 29, 2018, 07:57:49 »
Ah OK thanks.
Really gonna have to start putting pennies away and treat myself to Massive at some point I think!