Author Topic: Play Cursor not visible with fast tempos  (Read 1585 times)

Offline oxxi

  • Inspired artist
  • **
  • Posts: 56
    • my computer musiks
  • Operating System: Win 7
Play Cursor not visible with fast tempos
« on: April 02, 2018, 19:25:59 »
The play cursor isn't visible on fast tempos when I uncheck 'follow song'. Also when the tempo is slow enough to see the play cursor it is flickering. I didn't have this issue before and I'm on the same computer.
« Last Edit: April 02, 2018, 19:35:28 by oxxi »
////

Offline Saga Musix

  • OpenMPT Developers
  • *****
  • Posts: 6,443
  • aka Jojo
    • Download music, samples, VST plugins: Saga Musix Website
  • Operating System: Windows 7 x64
Re: Play Cursor not visible with fast tempos
« Reply #1 on: April 03, 2018, 14:31:06 »
This mostly happens because OpenMPT does not double-buffer the pattern display, which does not play well with the compositing window manager used by default in Windows 7.
There are several factors that may come into play why it just started happening for you, e.g. because the compositing window manager was not used (on Windows 7, it can be disabled if you are not using Aero, but Aero designs require it) or because you used a different audio configuration with a different period setting, which directly influences how often the display is updated.
Ultimately we need to start double-buffering the pattern editor (just like the instrument and sample editor), not doing it is a relict of old times, but until then, I can only recommend trying to experiment with the period settings in the sound card settings or disable the compositing window manager if you use the "classic" Windows look anyway.
» No support, bug reports, feature requests via private messages - they will not be answered. Use the forums and the issue tracker so that everyone can benefit from your post.

Offline oxxi

  • Inspired artist
  • **
  • Posts: 56
    • my computer musiks
  • Operating System: Win 7
Re: Play Cursor not visible with fast tempos
« Reply #2 on: April 03, 2018, 16:54:33 »
It looks like it's working now but it still flickers a bit and I'm on the classic windows theme, overall though it's tolerable. I had to lower the latency on my new soundcard's own device menu. I was originally reducing the latency on MPT itself but it didn't do anything. Also disabling the window manager didn't improve the issue. Thx for the help.
////

Offline Saga Musix

  • OpenMPT Developers
  • *****
  • Posts: 6,443
  • aka Jojo
    • Download music, samples, VST plugins: Saga Musix Website
  • Operating System: Windows 7 x64
Re: Play Cursor not visible with fast tempos
« Reply #3 on: April 03, 2018, 23:29:52 »
I had to lower the latency on my new soundcard's own device menu.
If you're talking about ASIO, the latency that OpenMPT likes to use is just an indication to the driver, it doesn't need to respect it at all - there is a minimum and maximum latency the driver reports, and oftentimes these two numbers are identical - namely the latency that you specify in the driver panel.
» No support, bug reports, feature requests via private messages - they will not be answered. Use the forums and the issue tracker so that everyone can benefit from your post.

Offline LPChip

  • Administrator
  • *****
  • Posts: 4,984
    • http://lpchip.nl
  • Operating System: Windows 10 Pro N (x64bit)
Re: Play Cursor not visible with fast tempos
« Reply #4 on: April 04, 2018, 15:37:43 »
Ah yeah, I reported the same issue. There already is a bug report in the Issue Tracker and Manx took a look at it.

This mainly happens with high latencies as far as I can tell and doesn't matter if you have samples or vst's. ASIO is far more noticable on my end, but it does happen with WASAPI too on very high latency settings.
"Heh, maybe I should've joined the compo only because it would've meant I wouldn't have had to worry about a damn EQ or compressor for a change. " - Atlantis
"yes.. I think in this case it was wishful thinking: MPT is makng my life hard so it must be wrong" - Rewbs