Author Topic: OpenMPT 1.28 and libopenmpt 0.4 removed platform support  (Read 2934 times)

Offline manx

  • OpenMPT Developers
  • *****
  • Posts: 198
OpenMPT 1.28 and libopenmpt 0.4 removed platform support
« on: February 18, 2018, 15:55:16 »
OpenMPT 1.28 and libopenmpt 0.4 removed platform support

For the general motivation, please refer to the detailed explanation at OpenMPT 1.27 and libopenmpt 0.3.0 remove support for old Windows and Wine systems and old C++ compilers

OpenMPT 1.28 has removed support for:

libopenmpt 0.4 has removed support for:



For OpenMPT 1.28 and libopenmpt 0.4, we were dditionally considering removing support for the following platforms:
  • GCC 4.8 (Ubuntu 14.04 LTS, CentOS 7)
  • GCC 4.9 (Debian 8)
  • Visual Studio 2015
We decided to not remove support for these platforms.



This post will be updated and clarified as needed. For each update, a short reply summarizing the update will be made in order to notify topic subscribers.
« Last Edit: November 24, 2018, 18:11:25 by manx »

Offline manx

  • OpenMPT Developers
  • *****
  • Posts: 198
Re: OpenMPT 1.28 and libopenmpt 0.4 removed platform support
« Reply #1 on: July 26, 2018, 09:37:39 »
libopenmpt 0.4 will also remove support for emscripten older than 1.38.1, thereby requiring a modern emscripten with native WebAssembly support.