Author Topic: (support) RC2 tracker quit with error  (Read 6147 times)

Offline l8

  • Active artist
  • *
  • Posts: 33
    • http://www.l8.democoder.ru
(support) RC2 tracker quit with error
« on: May 17, 2006, 18:36:00 »
situation:

os: win xpsp2
audio: behringer bca2000
driver setup: asio

i just create new song and then load some samples, when i try to play them on keyboard, or staring song tracker quits. problem solves by selecting dx driver.
nothing here-

Offline rewbs

  • OpenMPT Developers
  • *****
  • Posts: 578
(support) RC2 tracker quit with error
« Reply #1 on: May 17, 2006, 20:01:54 »
Can you try with the asio4all drivers?

Offline LPChip

  • Administrator
  • *****
  • Posts: 5,070
    • http://lpchip.nl
  • Operating System: Windows 10 Pro x64
(support) RC2 tracker quit with error
« Reply #2 on: May 17, 2006, 21:47:21 »
Looks like your not choosing the right buffersize or wrong frequency. Try altering the settings to be like your asio card.

To help you, what soundcard do you have? brand and type preffered.

And what version of the tracker are you using? MPT 1.16? RC2? latest beta?
"Heh, maybe I should've joined the compo only because it would've meant I wouldn't have had to worry about a damn EQ or compressor for a change. " - Atlantis
"yes.. I think in this case it was wishful thinking: MPT is makng my life hard so it must be wrong" - Rewbs

Offline l8

  • Active artist
  • *
  • Posts: 33
    • http://www.l8.democoder.ru
(support) RC2 tracker quit with error
« Reply #3 on: May 18, 2006, 03:42:03 »
Quote from: "LPChip"
Looks like your not choosing the right buffersize or wrong frequency. Try altering the settings to be like your asio card.

To help you, what soundcard do you have? brand and type preffered.

And what version of the tracker are you using? MPT 1.16? RC2? latest beta?


audio interface - BEHRINGER BCA2000.

version of tracker - latest RC2.
nothing here-

Offline rewbs

  • OpenMPT Developers
  • *****
  • Posts: 578
(support) RC2 tracker quit with error
« Reply #4 on: May 18, 2006, 08:46:21 »
Can you try with the asio4all drivers?

That way we can determine if it's some incompatibility with your ASIO driver.
http://www.asio4all.com/

Offline LPChip

  • Administrator
  • *****
  • Posts: 5,070
    • http://lpchip.nl
  • Operating System: Windows 10 Pro x64
(support) RC2 tracker quit with error
« Reply #5 on: May 18, 2006, 10:23:25 »
You also might wanna try to download the latest beta and install it over your RC2 (Its required for beta to first install RC2 anyway)

I've looked into the Specs and couldn't really make up how well ASIO is nativelly supported. It looks like it is, but without real specifications.

It speaks about sampling frequencies of 44.1k, 48k and 96k. I also read that transferring midi data over 48k won't work. I therefor suggest to set the bitrate setting to either 44.100 or 48.000 with 16 bits stereo sound.

I wouldn't install ASIO4ALL just yet, cus your device nativelly supports this. Also check your control panel, and set ASIO Monitoring to digital.
"Heh, maybe I should've joined the compo only because it would've meant I wouldn't have had to worry about a damn EQ or compressor for a change. " - Atlantis
"yes.. I think in this case it was wishful thinking: MPT is makng my life hard so it must be wrong" - Rewbs

Offline l8

  • Active artist
  • *
  • Posts: 33
    • http://www.l8.democoder.ru
(support) RC2 tracker quit with error
« Reply #6 on: May 18, 2006, 10:35:17 »
Quote from: "rewbs"
Can you try with the asio4all drivers?

That way we can determine if it's some incompatibility with your ASIO driver.
http://www.asio4all.com/


suggested driver works fine. but it loads my cpu 70-80% on simple 4ch oldchool mod. when i use native asio driver -  cpu load 40-50%. i know that such high cpu load depends on usb2.0 bus of my audio interface.

native driver click and pops, espesially when new pattern begins.
also strange things happen in control pannel. native panel showing 8 ms latency, and modplug window 10ms. sometimes 100ms, never the less then native control panel settings locked at 8 ms.
nothing here-

Offline l8

  • Active artist
  • *
  • Posts: 33
    • http://www.l8.democoder.ru
(support) RC2 tracker quit with error
« Reply #7 on: May 18, 2006, 10:42:04 »
Quote from: "LPChip"

I wouldn't install ASIO4ALL just yet, cus your device nativelly supports this. Also check your control panel, and set ASIO Monitoring to digital.


asio monitoring set to digital helped me! THANKS ALOT!
96khz, 32bit, 5 ms latency 20% load on classic mod. with no cliks..
but never the less, modplug  shows 10ms delay (control panel - 5ms), i think that tracker has wrong detection of latency.
nothing here-

Offline LPChip

  • Administrator
  • *****
  • Posts: 5,070
    • http://lpchip.nl
  • Operating System: Windows 10 Pro x64
(support) RC2 tracker quit with error
« Reply #8 on: May 18, 2006, 11:00:59 »
Quote from: "l8"
Quote from: "LPChip"

I wouldn't install ASIO4ALL just yet, cus your device nativelly supports this. Also check your control panel, and set ASIO Monitoring to digital.


asio monitoring set to digital helped me! THANKS ALOT!
96khz, 32bit, 5 ms latency 20% load on classic mod. with no cliks..
but never the less, modplug  shows 10ms delay (control panel - 5ms), i think that tracker has wrong detection of latency.


Not really. 10ms is just <48 samples which in Dx produces 10ms. This screen was never altered. Its more of an indication. New people don't know what 48 samples mean. So they usually set it to max which gets a huge delay etc.

EDIT: since this not a bug, but a support issue, closing the status (on top)
"Heh, maybe I should've joined the compo only because it would've meant I wouldn't have had to worry about a damn EQ or compressor for a change. " - Atlantis
"yes.. I think in this case it was wishful thinking: MPT is makng my life hard so it must be wrong" - Rewbs