Choppy tracker module pattern scrolling ?

Started by vind, February 02, 2015, 03:40:24

Previous topic - Next topic


Although it may be subtle, I've noticed that the motion of the scrolling pattern display always appears inconsistent and choppy, particularly at higher tempos. The same thing also appears to be the case with the module pattern visuals in XMPlay – but it doesn't seem to be related to system resources or processing power, so I'm wondering what could be the cause ? I sometimes capture module pattern displays to use for use in video presentations, so I find it a bit annoying that the framerate of the scrolling always appears choppy prior to recording.


What type of Sound Card backend are you using? And what are your Latency and Period settings?
In particular, if your Period setting is above about 10ms (or the Latency is about twice as much in case of backends that do not allow you to set the period), this will inevitably result in perceivable jitter in the pattern display.

Saga Musix

In addition to what manx said, I find it intersting that you directly want to rule out any system problem given that two applications that do not share any common code have the same problem. Keep in mind that Windows is not a real-time operating system, and especially bad drivers (most often culprit seem to be wifi drivers) can harm the system's real-time performance quite heavily.
If setting the period and latency values to reasonably low values doesn't fix your problem, I'd  normally recommend to check for problematic drivers using DPC Latency Checker, but according to the creator it does not work reliably with Windows 8. So since DPC Latency Checker will most likely not give you any usable results, and in case you are using a wireless network, it could be helpful to disable that temporarily and see if the jitter disappears.
» No support, bug reports, feature requests via private messages - they will not be answered. Use the forums and the issue tracker so that everyone can benefit from your post.


Thanks for the advice, guys. Disabling the wireless network actually made a pretty noticable difference. Gotta keep that one in mind. ;)