Author Topic: cannot upgrade to latest version -- get an error  (Read 2505 times)

Offline justinrpg

  • Inspired artist
  • **
  • Posts: 65
  • Operating System: Windows 7
cannot upgrade to latest version -- get an error
« on: July 06, 2011, 00:48:49 »
doesn't matter how many times I try, the same error occurs during installation of the new version of MPT... the error reads

C:\Program Files\OpenMPT\mptrack.exe

an error occurred while trying to replace the existing file:
DeleteFile failed; code 5.
Access is denied


it does this every time I try to install the latest version of MPT, it will not successfully install, that error comes up every time I try to install the latest ModPlug Tracker

Offline LPChip

  • Administrator
  • *****
  • Posts: 5,126
    • http://lpchip.nl
  • Operating System: Windows 10 Pro x64
Re: cannot upgrade to latest version -- get an error
« Reply #1 on: July 06, 2011, 06:28:39 »
Do you happen to have OpenMPT already open?

Perhaps you're trying to install with a restricted user? Do you have administrative privleges or otherwise access to the program files directory?
"Heh, maybe I should've joined the compo only because it would've meant I wouldn't have had to worry about a damn EQ or compressor for a change. " - Atlantis
"yes.. I think in this case it was wishful thinking: MPT is makng my life hard so it must be wrong" - Rewbs

Offline justinrpg

  • Inspired artist
  • **
  • Posts: 65
  • Operating System: Windows 7
Re: cannot upgrade to latest version -- get an error
« Reply #2 on: July 06, 2011, 14:40:16 »
it is not open & yes I am the administrator... it is my computer

Offline Saga Musix

  • OpenMPT Developers
  • *****
  • Posts: 7,358
  • aka Jojo
    • Download music, samples, VST plugins: Saga Musix Website
  • Operating System: Windows 10 x64
Re: cannot upgrade to latest version -- get an error
« Reply #3 on: July 06, 2011, 15:37:45 »
Maybe the file is locked by something, that does happen quite often in Windows, but that's not OpenMPT's fault. Can you manually delete the file, or does running the uninstaller first help?
ยป No support, bug reports, feature requests via private messages - they will not be answered. Use the forums and the issue tracker so that everyone can benefit from your post.

Offline justinrpg

  • Inspired artist
  • **
  • Posts: 65
  • Operating System: Windows 7
Re: cannot upgrade to latest version -- get an error
« Reply #4 on: July 06, 2011, 17:39:17 »
I got it working after uninstalling the old one, but I am having a lot of problems with the new version (see my next two topics)