Author Topic: .53 Row Spacing entry  (Read 2620 times)

Offline Harbinger

  • Extreme artist
  • *****
  • Posts: 1,142
  • Gender: Male
  • Operating System: Windows XP
.53 Row Spacing entry
« on: July 10, 2009, 23:49:32 »
Full Version:
OpenMPT v1.17.02.53

Has the bug occured in previous versions? If yes, please specify version(s): Not sure.


Description of the bug: You can enter a jump value in Row Spacing greater than 16 but the jump is maximized to 16. Either prevent values higher than 16, reset whatever value is entered to 16 if it's greater, or allow for greater jumps. I opt for the latter.


How often does it happen?: Always.


How to reproduce (step by step description): Type in a number into the Row Spacing field and navigate. 16 is the max, no matter what the field shows.

Offline Sam_Zen

  • Extreme artist
  • *****
  • Posts: 3,689
    • http://www.xs4all.nl/~samzen/
.53 Row Spacing entry
« Reply #1 on: July 11, 2009, 00:33:19 »
It should be at least the second. It is silly that '24' still stays in the box, after a jump of 16.
I would support the latter, with the condition, that it's less that the nr of rows of the pattern,
or , if the count goes beyond the transition to the next pattern, it's calculated to the right position there.

Tested : if I enter '13' the jumps stop at '52' (rowlength 64), no jump to next pattern.
0.618033988

Offline Saga Musix

  • OpenMPT Developers
  • *****
  • Posts: 6,689
  • aka Jojo
    • Download music, samples, VST plugins: Saga Musix Website
  • Operating System: Windows 10 x64
.53 Row Spacing entry
« Reply #2 on: July 11, 2009, 10:46:35 »
confirmed both. should be fixed.

EDIT: Fixed both, set maximum row spacing limit to 64.
» No support, bug reports, feature requests via private messages - they will not be answered. Use the forums and the issue tracker so that everyone can benefit from your post.

Offline Saga Musix

  • OpenMPT Developers
  • *****
  • Posts: 6,689
  • aka Jojo
    • Download music, samples, VST plugins: Saga Musix Website
  • Operating System: Windows 10 x64
.53 Row Spacing entry
« Reply #3 on: September 22, 2009, 21:42:43 »
Please confirm that this is fixed in OpenMPT 1.17.03.02. You may set the S=C flag in the first post yourself then, without further comments.
» No support, bug reports, feature requests via private messages - they will not be answered. Use the forums and the issue tracker so that everyone can benefit from your post.

Offline Harbinger

  • Extreme artist
  • *****
  • Posts: 1,142
  • Gender: Male
  • Operating System: Windows XP
.53 Row Spacing entry
« Reply #4 on: October 05, 2009, 14:25:21 »
Works beautifully! Can enter values up to 64, but doesn't jump beyond first row of next pattern (i can live with that).