Author Topic: Keyboard layout problems  (Read 5329 times)

Offline Kak

  • Shy artist
  • Posts: 4
Keyboard layout problems
« on: January 12, 2008, 00:18:24 »
I have an spanish keyboard and I'm learning tracking right now (nice tutorial at the wiki)!

However there are some weird things that I don't know if it's due to my layout or if trackers work this way

In example, I can't get any B or B# into the patterns. In example, Q is C-4, T is E-4, P is A-4, the next of the P is A-5 and the next one is == which I don't even know what it is :)

From left to right again, L is G#5, next is ~~ (stop) and next A#5 (A5 is on top of A#5), and same for the bottom row. I can't even find any B and B#

Is the english layout the same?

Offline bvanoudtshoorn

  • Extreme artist
  • *****
  • Posts: 1,053
  • Gender: Male
    • Barryvan
Keyboard layout problems
« Reply #1 on: January 12, 2008, 02:00:28 »
Well, "B#" is just "C", just like "E#" is just "F". The easiest way to fix this up is to go into the setup dialog, open up the keyboard tab, select "Pattern Editor - Note Col", and change the keys assigned there.

Most people have one of two types of configuration:

1. Linear arrangement (which I use, because you get more notes.)


2. "Piano" arrangement (which I don't, so this might be inaccurate :))

This sounds as though it might be what you have set up by default.

I'm not sure how a Spanish keyboard looks, though... The basic idea should work on just about any keyboard, though.


"==" is a note-off command. It stops the note currently playing (using any volume envelopes you might have set up).
"^^" is a note-cut command. It stop the note currently playing straight away, without any fades or whatever.

Offline Sam_Zen

  • Extreme artist
  • *****
  • Posts: 3,689
    • http://www.xs4all.nl/~samzen/
Keyboard layout problems
« Reply #2 on: January 12, 2008, 03:25:35 »
Nice material, these pics. Thanks Barry. :)
0.618033988

Offline bvanoudtshoorn

  • Extreme artist
  • *****
  • Posts: 1,053
  • Gender: Male
    • Barryvan
Keyboard layout problems
« Reply #3 on: January 12, 2008, 03:28:15 »
That's ok. ;)

Offline Kak

  • Shy artist
  • Posts: 4
Keyboard layout problems
« Reply #4 on: January 12, 2008, 13:07:44 »
Quote from: "bvanoudtshoorn"
Well, "B#" is just "C", just like "E#" is just "F". The easiest way to fix this up is to go into the setup dialog, open up the keyboard tab, select "Pattern Editor - Note Col", and change the keys assigned there.


Thanks!
I don't know exactly what I modified in that menu option but it seems to work as your drawings (nice, btw!)
I'll cross the fingers and expect to be working with this layout for some years :)

Thanks again! :)
Kak

Offline LPChip

  • Administrator
  • *****
  • Posts: 5,125
    • http://lpchip.nl
  • Operating System: Windows 10 Pro x64
Keyboard layout problems
« Reply #5 on: January 12, 2008, 15:07:50 »
The default layout is the 1st picture, but it can be configured as the second picture from the setup menu. Also there are alot of presets around which usually use the 2nd layout.
"Heh, maybe I should've joined the compo only because it would've meant I wouldn't have had to worry about a damn EQ or compressor for a change. " - Atlantis
"yes.. I think in this case it was wishful thinking: MPT is makng my life hard so it must be wrong" - Rewbs

Offline Kak

  • Shy artist
  • Posts: 4
Keyboard layout problems
« Reply #6 on: January 16, 2008, 09:55:27 »
One more question about ^^, is it supported on MOD files?

I mean, if I use it, modplug turns it into B-8 next time I load it, making some high pitch noises instead of note cut :(

Also I've found that if I put v32 in the volume column, when saving to mod changes it to C10... shouldn't it be C20 ?

Offline LPChip

  • Administrator
  • *****
  • Posts: 5,125
    • http://lpchip.nl
  • Operating System: Windows 10 Pro x64
Keyboard layout problems
« Reply #7 on: January 16, 2008, 10:01:00 »
The MOD format is the oldest format supported by OpenMPT. The formats has been improved alot during the time. First with S3M, then XM then IT. MOD is a very basic format with alot of limitations. One of the things is the range notes can be played in. B-8 is outside of that range.

A small tip would be to learn tracking in the IT format and once you understand it and still want to work with MOD, switch later. That way you'll be familiar with the interface so there are less things that can go wrong.
"Heh, maybe I should've joined the compo only because it would've meant I wouldn't have had to worry about a damn EQ or compressor for a change. " - Atlantis
"yes.. I think in this case it was wishful thinking: MPT is makng my life hard so it must be wrong" - Rewbs

Offline Saga Musix

  • OpenMPT Developers
  • *****
  • Posts: 7,345
  • aka Jojo
    • Download music, samples, VST plugins: Saga Musix Website
  • Operating System: Windows 10 x64
Keyboard layout problems
« Reply #8 on: January 16, 2008, 15:10:16 »
MOD had only octaves from C1 to B3 which is C4 to B6 in OpenMPT. You can't use ^^^ in MOD and XM files, you have to use C00 in these formats.

About your v32 issuse... i haven't tested this for ages, but it always worked correctly. probably your sample has the "global volume" setting set to 32 (half volume). MOD files don't have a global volume setting per sample and so this must be converted...
ยป No support, bug reports, feature requests via private messages - they will not be answered. Use the forums and the issue tracker so that everyone can benefit from your post.