Author Topic: .48 Adding Channels: Wrong panning behaviour  (Read 2801 times)

Offline Saga Musix

  • OpenMPT Developers
  • *****
  • Posts: 6,641
  • aka Jojo
    • Download music, samples, VST plugins: Saga Musix Website
  • Operating System: Windows 10 x64
.48 Adding Channels: Wrong panning behaviour
« on: July 01, 2007, 15:43:46 »
Full Version:
OpenMPT v1.17.02.48

Has the bug occured in previous versions? If yes, please specify version(s): (This option is optional, and doesn't need research. But in case you know...)
Dunno


Description of the bug:
When i add some channels to an exisiting (IT) module, the channel pannings are set to left and right (like in standard MOD files), but the sliders on the general tab show that the channel is panned to the middle. If i play the module, the sound is indeed on the left or right side, not in the middle.
» No support, bug reports, feature requests via private messages - they will not be answered. Use the forums and the issue tracker so that everyone can benefit from your post.

Offline seventhson

  • Inspired artist
  • **
  • Posts: 88
.48 Adding Channels: Wrong panning behaviour
« Reply #1 on: July 01, 2007, 17:16:49 »
Have been experiencing this bug as well,it doesn't allways happen as far as i can tell and it seems to go away after moving the pan slider to a certain position and then moving it back to the centre while playing.

Offline Relabsoluness

  • OpenMPT Developers
  • *****
  • Posts: 709
Re: (S=O) .48 Adding Channels: Wrong panning behaviour
« Reply #2 on: July 01, 2007, 22:33:29 »
Quote from: "Jojo"
When i add some channels to an exisiting (IT) module

Do you know does it have any difference whether you use the song properties dialog or the 'Add channel' option in right-click-menu on channel headers to add the channels?

Offline Saga Musix

  • OpenMPT Developers
  • *****
  • Posts: 6,641
  • aka Jojo
    • Download music, samples, VST plugins: Saga Musix Website
  • Operating System: Windows 10 x64
.48 Adding Channels: Wrong panning behaviour
« Reply #3 on: July 02, 2007, 12:51:15 »
As it does not always happen, i was not able to create a testcase, sorry. But I'll try to find that out. So far, i only spotted it in the General Tab dialog.
» No support, bug reports, feature requests via private messages - they will not be answered. Use the forums and the issue tracker so that everyone can benefit from your post.