Author Topic: 1.17.02.28 Importing midi tracks won't load all sounds  (Read 10873 times)

Offline LB

  • Active artist
  • *
  • Posts: 16
    • http://www.LB-Stuff.com/
.28 Importing midi tracks won't load all sounds
« Reply #15 on: August 05, 2009, 23:12:23 »
I am having this issue too, and would like it to be fixed. I have here and ready on my website a MIDI file that plays correctly in Windows Media Player, but lacks some of the sounds in ModPlug:
http://www.LB-Stuff.com/XMUSIC6.MID

Also will is be possible to load all the copywright information into the song message?

Thanks,
-LB
Don't feed the bunnies. They will bring thier friends next time.

~MMF2 Developer user~
LB-Stuff - My Website

Offline Saga Musix

  • OpenMPT Developers
  • *****
  • Posts: 6,676
  • aka Jojo
    • Download music, samples, VST plugins: Saga Musix Website
  • Operating System: Windows 10 x64
.28 Importing midi tracks won't load all sounds
« Reply #16 on: August 06, 2009, 07:44:01 »
The message is written to a Track, which is, as far as I know, a channel. Correct me if I'm wrong.
» No support, bug reports, feature requests via private messages - they will not be answered. Use the forums and the issue tracker so that everyone can benefit from your post.

Offline Saga Musix

  • OpenMPT Developers
  • *****
  • Posts: 6,676
  • aka Jojo
    • Download music, samples, VST plugins: Saga Musix Website
  • Operating System: Windows 10 x64
.28 Importing midi tracks won't load all sounds
« Reply #17 on: August 07, 2009, 16:26:24 »
Well, modplug DOES load a copyright message into the comment field. Isn't that what you are looking for? I see that modplug triggers a heap overflow or whatever when loading any MIDI file, so I wonder if it would be easier to just rewrite the whole loader...
» No support, bug reports, feature requests via private messages - they will not be answered. Use the forums and the issue tracker so that everyone can benefit from your post.