Author Topic: OpenMPT 1.28 and libopenmpt 0.4 removed platform support  (Read 1089 times)

Offline manx

  • OpenMPT Developers
  • *****
  • Posts: 188
OpenMPT 1.28 and libopenmpt 0.4 removed platform support
« on: February 18, 2018, 15:55:16 »
OpenMPT 1.28 and libopenmpt 0.4 removed platform support

This post will be updated and clarified as needed. For each update, a short reply summarizing the update will be made in order to notify topic subscribers.

For the general motivation, please refer to the detailed explanation at OpenMPT 1.27 and libopenmpt 0.3.0 remove support for old Windows and Wine systems and old C++ compilers

OpenMPT 1.28 has removed support for:

libopenmpt 0.4 has removed support for:

OpenMPT 1.28 will remove support for the following platforms:

    libopenmpt 0.4 will remove support for the following platforms:
    • GCC 4.8; thereby removing support for Ubuntu 14.04 LTS and CentOS 7 (there are newer toolchains available for CentOS 7 though)

    For OpenMPT 1.28 and libopenmpt 0.4, we are additionally considering (unlikely as of now) removing support for:
    • GCC 4.9; thereby removing support for Debian 8
    • Visual Studio 2015



    This post will be updated and clarified as needed. For each update, a short reply summarizing the update will be made in order to notify topic subscribers.
    « Last Edit: July 14, 2018, 11:16:27 by manx »