Author Topic: Export problems with Lucid VST  (Read 204 times)

Offline Muzozavr

  • Active artist
  • *
  • Posts: 13
Export problems with Lucid VST
« on: September 04, 2017, 00:46:50 »
I found this free plugin called "Lucid" with some amazing, kickass sounds: https://www.kvraudio.com/product/lucid-by-xenobioz

Tried it out and wrote something with it... but now I have problems. First of all, sometimes it doesn't immediately play properly and takes its sweet time to actually initialize and play the track without the first or the second instrument going quiet. This is something I can live with, but the other problem is much worse: I can't export my tune without one specific instrument breaking itself and resetting to something lame... I guess it's the default init value.

The preset that breaks is number 39, "PL Pluck" in the first preset bank. Even after pushing it to slot 7 (instead of slot 1) or moving the instrument to a different channel, the problem persists. It exports in a broken way. Slow render doesn't help, cleaning plugin buffers doesn't help, instrument mode doesn't help. Updated my OpenMPT just now, to see if that helps (I originally had some ancient 1.25 shit), but no, even that doesn't help, the export of that specific instrument is still broken.

Is there something I can do to make it work properly? I really love the tune, it'd be a shame to give up on it because of export issues...

Offline Saga Musix

  • OpenMPT Developers
  • *****
  • Posts: 6,236
  • aka Jojo
    • Download music, samples, VST plugins: Saga Musix Website
  • Operating System: Windows 7 x64
Re: Export problems with Lucid VST
« Reply #1 on: September 04, 2017, 11:30:59 »
This plugin was made with SynthEdit, and I have a hunch the problem is similar to stuff we have encountered wtih buggy SynthMaker plugins in the past. You will probably have to use the same workaround for SynthMaker plugins as described in the manual.
ยป No support, bug reports, feature requests via private messages - they will not be answered. Use the forums and the issue tracker so that everyone can benefit from your post.

Offline Muzozavr

  • Active artist
  • *
  • Posts: 13
Re: Export problems with Lucid VST
« Reply #2 on: September 04, 2017, 12:23:04 »
Not sure if it's the same bug, but the described workaround should definitely work, since it plays just fine within OpenMPT itself. Thanks!