Author Topic: Midi In/out problem?  (Read 886 times)

Offline oxxi

  • Inspired artist
  • **
  • Posts: 53
    • my computer musiks
  • Operating System: Win 7
Midi In/out problem?
« on: June 17, 2016, 01:59:31 »
I hope I'm wrong but it seems there is an issue with the Midi plugin in openmpt not working. Modplug sees my midi devices but I can't enter midi notes with my midi keyboard or send midi notes. I've done this many times before so I'm not sure what's going on. I'm using the Teenage Engineering Oblab and the Roland Um-one. I've never had problems with theses devices communicating with modplug before. I have restarted openmpt, my computer, and still can't enter notes. Also another thing is if I have an instrument and insert a midi/plugin, I can't play the instrument at all with the computer keyboard or midi device.  :'(
////

Offline oxxi

  • Inspired artist
  • **
  • Posts: 53
    • my computer musiks
  • Operating System: Win 7
Re: Midi In/out problem?
« Reply #1 on: June 17, 2016, 03:31:22 »
It looks like I had to restart Oplab itself even after a computer reboot and then modplug started responding. I don't know what it is but the midi plugin UX interaction seems kinda quirky. I really don't like that there is a pop-up when enabling the midi-plugin on an instrument. That should be set in the midi window settings.
////

Offline Saga Musix

  • OpenMPT Developers
  • *****
  • Posts: 6,252
  • aka Jojo
    • Download music, samples, VST plugins: Saga Musix Website
  • Operating System: Windows 7 x64
Re: Midi In/out problem?
« Reply #2 on: June 17, 2016, 11:28:37 »
Quote
It looks like I had to restart Oplab itself even after a computer reboot
Please always verify issues like this with a tiny MIDI program like SendSX before investigating further - verifying that any MIDI application works should always be done first before searching for a fault in a specific one (i.e. OpenMPT).

Quote
I don't know what it is but the midi plugin UX interaction seems kinda quirky. I really don't like that there is a pop-up when enabling the midi-plugin on an instrument. That should be set in the midi window settings.
What popup? The plugin GUI? It is fully intentional that this is not set in the default MIDI settings, because you can choose a different MIDI device for every plugin instance in every song. If every MIDI plugin instance would be using the same MIDI device, the plugin would entirely miss its point.
ยป No support, bug reports, feature requests via private messages - they will not be answered. Use the forums and the issue tracker so that everyone can benefit from your post.