Author Topic: Linux and Midi  (Read 1590 times)

Offline pixelblip

  • Shy artist
  • Posts: 3
Linux and Midi
« on: June 11, 2016, 13:29:39 »
Hello!
I've started using Open MPT today. It's very well thought out.

I'm using Linux and Ubuntu ...sorry! It runs fine in Wine......the only problem is when I attach my Korg Midi keyboard ( Microkey) and start playing notes into it it starts the transport controls. No matter if I switch that off in the midi options. So I can't really enter notes with it unless I use the QWERTY keyboard to go down a line in step time fashion.

Does anyone else use Linux and Open MPT?
Thanks for your advice.
PS I do not have jack switched on....just using it without.

Offline Saga Musix

  • OpenMPT Developers
  • *****
  • Posts: 6,292
  • aka Jojo
    • Download music, samples, VST plugins: Saga Musix Website
  • Operating System: Windows 7 x64
Re: Linux and Midi
« Reply #1 on: June 11, 2016, 13:52:18 »
Just to be absolutely sure, you have both "Continue song as soon as MIDI notes are being received" and "Respond to Play /... messages" disabled?
ยป No support, bug reports, feature requests via private messages - they will not be answered. Use the forums and the issue tracker so that everyone can benefit from your post.

Offline pixelblip

  • Shy artist
  • Posts: 3
Re: Linux and Midi
« Reply #2 on: June 11, 2016, 13:54:28 »
Thanks for trying to help.

Yes I do have that command disabled.

I've also plugged in another keyboard to check this ( Akai synthstation) and it's doing the same thing.

I plugged it straight into the USB socket just to check that as well.

If someone could take a look at this I would be so grateful. Thank you.


Offline manx

  • OpenMPT Developers
  • *****
  • Posts: 158
Re: Linux and Midi
« Reply #3 on: June 11, 2016, 13:55:13 »
the only problem is when I attach my Korg Midi keyboard ( Microkey) and start playing notes into it it starts the transport controls. No matter if I switch that off in the midi options.
That should not happen. It does behave as expected for me in Wine.

Offline manx

  • OpenMPT Developers
  • *****
  • Posts: 158
Re: Linux and Midi
« Reply #4 on: June 11, 2016, 13:57:37 »
I'm using Linux and Ubuntu ...sorry! It runs fine in Wine......the only problem is when I attach my Korg Midi keyboard ( Microkey) and start playing notes into it it starts the transport controls. No matter if I switch that off in the midi options.
...
PS I do not have jack switched on....just using it without.
Just to be sure we are talking about the same thing here: Are you saying that entering MIDI notes starts playback in OpenMPT or are you saying entering MIDI notes starts your system-wide JACK transport?
In the latter case, this has absolutely nothing to do with OpenMPT.

Offline pixelblip

  • Shy artist
  • Posts: 3
Re: Linux and Midi
« Reply #5 on: June 11, 2016, 14:03:10 »
Oh dear my apologies. User error! You are correct it doesn't advance when that command is unticked. I had 'Step' set to 0 and it wasn't advancing down.
Sorry......to waste time. I was trying lots of things.

It's great it works in Linux. Thank you!

Offline manx

  • OpenMPT Developers
  • *****
  • Posts: 158
Re: Linux and Midi
« Reply #6 on: June 11, 2016, 14:20:47 »
It's great it works in Linux. Thank you!
As it should ;) Wine is a supported platform for OpenMPT. Feel free to report any problem you encounter.