Author Topic: Keyboard beeps when trying to play samples. Sticky keys are turned off.  (Read 3452 times)

Offline Blacklight

  • Shy artist
  • Posts: 5
  • Operating System: Windows
As the title says, I have an annoying problem.  When I push a key to play a sample, the sample plays but when I release the key, the key also beeps.  Sticky keys and all the filter options associated with sticky keys are turned off.  I don't know what's causing this but it's getting really annoying to hear the keyboard beep every time I play a sample in a song where I'm hand placing hundreds of samples and all I'm hearing is the sample playing followed by a "DING!"  I'm going insane!!!!  Can anyone help me?  I thought this was sticky keys but obviously it's not and it's something else!

Offline Saga Musix

  • OpenMPT Developers
  • *****
  • Posts: 6,292
  • aka Jojo
    • Download music, samples, VST plugins: Saga Musix Website
  • Operating System: Windows 7 x64
I never had that problem so I honestly have no idea what could cause it. Does it happen anywhere, or maybe just in particular windows such as the pattern editor? OpenMPT has its own low-level keyboard handler that intercepts keys before they are being sent to anything that could emit a beep.
Seeing that you already posted a few years ago on this forum, did this issue just come up recently or did it always happen?

My only suggestion right now would be to turn off all Windows sounds, which will make the rest of your daily life less annoying too. ;)
« Last Edit: November 03, 2015, 11:30:26 by Saga Musix »
» No support, bug reports, feature requests via private messages - they will not be answered. Use the forums and the issue tracker so that everyone can benefit from your post.

Offline Blacklight

  • Shy artist
  • Posts: 5
  • Operating System: Windows
It happens everywhere.  In the pattern editor and in the sample editor.  Whenever I play a sample.  I'll push the key and when I release the key there's a "DING!"

Offline Saga Musix

  • OpenMPT Developers
  • *****
  • Posts: 6,292
  • aka Jojo
    • Download music, samples, VST plugins: Saga Musix Website
  • Operating System: Windows 7 x64
This might be far-fetched, but do you use any keyboard-specific software, such as IntelliSense for macro keys? Also, as said it would be good to know whether this happened in older versions too.
» No support, bug reports, feature requests via private messages - they will not be answered. Use the forums and the issue tracker so that everyone can benefit from your post.

Offline Harbinger

  • Extreme artist
  • *****
  • Posts: 1,137
  • Gender: Male
  • Operating System: Windows XP
I don't know if it's related but I have a similar problem, that I've just learned to put up with.

If I keep the note key pressed when previewing a sample in the Tree View, I get the Windows ding/beep, and another listing in the folder is chosen, corresponding to the note I'm pressing, for example. If a select a sound file in the Tree View, and then press V on the keyboard, the sound plays, but immediately Windows (I presume) selects the first file in the folder that starts with V, then starts beeping if I keep the V held down. It's annoying as hell, but I just release the key to stop it.

I'm using Windows XP

Offline Saga Musix

  • OpenMPT Developers
  • *****
  • Posts: 6,292
  • aka Jojo
    • Download music, samples, VST plugins: Saga Musix Website
  • Operating System: Windows 7 x64
No, it's not related, it's just that the tree view has its own keyboard actions that seem to take precedence when keeping keys pressed. Annoying as it might be, I don't know how to fix it right now.
There's no need to keep the key pressed though, the note will just sound until you stop playback or enter a note-off (yes, that also works in the tree view).
« Last Edit: November 05, 2015, 00:31:11 by Saga Musix »
» No support, bug reports, feature requests via private messages - they will not be answered. Use the forums and the issue tracker so that everyone can benefit from your post.

Offline Blacklight

  • Shy artist
  • Posts: 5
  • Operating System: Windows
I never installed the Intellisense software for this keyboard.  The last time I used Intellisense, with my keyboard and mouse combo, it completely screwed things up with my gaming.  It tended to make half of  make my games think that I only had a mouse and that was it, or a keyboard and that was it, but not both.  Other times, it would cause the keyboard to cut out when I was using the mouse or vise versa. The Intellesense software is horrible trash. 

I usually am able to get around it somewhat by quickly pushing the key and having the sample play all the way through, but sometimes, it does get stuck in a situation where even when I hit that key and release it, it still makes the "Ding!" on release.  I'm going to have to figure out when that occurs.  It may be after accessing the samples from the tree view.  I'll see if I can reproduce it and get back to you. I know that there are some times when it does it and some times when it doesn't and some times when it just locks into doing it all the time.
« Last Edit: November 21, 2015, 06:16:54 by Blacklight »

Offline Saga Musix

  • OpenMPT Developers
  • *****
  • Posts: 6,292
  • aka Jojo
    • Download music, samples, VST plugins: Saga Musix Website
  • Operating System: Windows 7 x64
Can you maybe check if "Repeat notes on hold" -> [Yes] in the keyboard setup makes a difference?
If it doesn't, it would still be interesting to know if the same problem exists with previous versions. Maybe you can download an old version of OpenMPT 1.18 and install it in portable mode to a different directory (don't forget to also uncheck the file associations in the installer)?
» No support, bug reports, feature requests via private messages - they will not be answered. Use the forums and the issue tracker so that everyone can benefit from your post.

Offline Blacklight

  • Shy artist
  • Posts: 5
  • Operating System: Windows
I just wanted to let you know that setting the"Repeat notes on hold" -> [Yes]" seems to have worked for me.  I only seem to get the "ding" if I click the mouse button at the same time I happen to be holding down the keyboard key to play the sample.

Offline Saga Musix

  • OpenMPT Developers
  • *****
  • Posts: 6,292
  • aka Jojo
    • Download music, samples, VST plugins: Saga Musix Website
  • Operating System: Windows 7 x64
I'm still unable to understand how this is supposed to happen. The "Ding" sound should only be heard if keyboard input is being directed to a window that does currently not accept keyboard input (e.g. a locked edit control). However, if you are working in the pattern editor this is not the case. I was also unable to reproduce this on several Windows systems. Which Windows version are you using? You already stated that you are not using Intellisense but do you maybe use any other global programs that "enhance" or otherwise modify system behaviour?

Quote
I only seem to get the "ding" if I click the mouse button at the same time I happen to be holding down the keyboard key to play the sample.
This can be expected depending on where you click, as mentioned above. If you for example click on the tab switcher in OpenMPT, keyboard input is redirected to the tab switcher but it doesn't know what to do with this input, so it plays that sound. This is nothing something we can or want to change, but you can always disable that sound in your system sound scheme (I think it's the "Asterisk" sound that needs to be disabled).
» No support, bug reports, feature requests via private messages - they will not be answered. Use the forums and the issue tracker so that everyone can benefit from your post.

Offline LDAsh

  • Active artist
  • *
  • Posts: 15
    • Violation Entertainment
  • Operating System: WinXP/Win7
Actually I had this issue too, not just with OpenMPT but other software, and my solution was to simply open the case and rip the PC speaker out.  If I have troubles booting one day, I can just plug it in again when I need to hear error codes, otherwise this thing is simply there to annoy people trying to sleep. :P

Offline Saga Musix

  • OpenMPT Developers
  • *****
  • Posts: 6,292
  • aka Jojo
    • Download music, samples, VST plugins: Saga Musix Website
  • Operating System: Windows 7 x64
Well, it's even easier these days, you just need to remove that one sound from the Windows sound scheme... But sometimes that's not a solution. ;)
» No support, bug reports, feature requests via private messages - they will not be answered. Use the forums and the issue tracker so that everyone can benefit from your post.

Offline LPChip

  • Administrator
  • *****
  • Posts: 4,956
    • http://lpchip.nl
  • Operating System: Windows 10 Pro N (x64bit)
Or you can disable the windows hardware component called "beep" which becomes visible if you check "show all devices" in Device Manager. This hardware component will use the pc speaker when no sound device is detected and an error is received by the OS.
"Heh, maybe I should've joined the compo only because it would've meant I wouldn't have had to worry about a damn EQ or compressor for a change. " - Atlantis
"yes.. I think in this case it was wishful thinking: MPT is makng my life hard so it must be wrong" - Rewbs