Author Topic: openmpt deleting from multisampled instruments.  (Read 556 times)

Offline sso

  • Workaholic artist
  • ***
  • Posts: 134
  • Operating System: win 7 (64)
openmpt deleting from multisampled instruments.
« on: February 21, 2013, 06:09:34 »
id save a song in 20.02 version, and next time id open it up, some of the multi sample inst´s would have some notes randomly assigned to some other sample and the sample originally assigned to that note, gone.

is that problem gone with the 21. or?

(interestingly the song sounded better without those particular samples it deleted, so hey, but lol .: ))

Offline Saga Musix

  • OpenMPT Developers
  • *****
  • Posts: 5,303
  • aka Jojo
    • Download music, samples, VST plugins: Saga Musix Website
  • Operating System: Windows 7 x64
Re: openmpt deleting from multisampled instruments.
« Reply #1 on: February 21, 2013, 12:51:21 »
This might have been fixed already, check http://sagagames.de/stuff/mptrack.exe
If it hasn,'t it might be related to http://bugs.openmpt.org/view.php?id=348
But I couldn't reproduce this anymore after fixing some stuff, so if you still can with the test version from above, please provide a simple test case that can reproduce the problem.
» No support, bug reports, feature requests via private messages - they will not be answered. Use the forums and the issue tracker.

Offline sso

  • Workaholic artist
  • ***
  • Posts: 134
  • Operating System: win 7 (64)
Re: openmpt deleting from multisampled instruments.
« Reply #2 on: February 24, 2013, 09:07:56 »
im trying out 21 now, ill let you know if its still the same, thanks.

Offline sso

  • Workaholic artist
  • ***
  • Posts: 134
  • Operating System: win 7 (64)
Re: openmpt deleting from multisampled instruments.
« Reply #3 on: February 27, 2013, 13:02:30 »
yes, apparently it seems to be fixed. :)  thanks.