Author Topic: 1.17.02.52 Problem with VST2.4 plugin  (Read 3236 times)

Offline seventhson

  • Inspired artist
  • **
  • Posts: 88
1.17.02.52 Problem with VST2.4 plugin
« on: September 09, 2009, 17:56:09 »
When trying to load an instance of Cytomic's The Glue compressor openmpt (tested on 2.45 and 2.52) tells me it isn't a valid VST.
I posted on KVR to see if others were having problems as well, and Andrew Simper (the developer of the plugin) told me the plugin is VST2.4 and the host needs to be able to handle 4 in 2 output plugins.
So i'm guessing mpt has either a problem with VST2.4 or a problem with 4 in 2 outputs.
He also said the following:

"Please let the your host developer know that they can contact me ( www.cytomic.com/contact ) if they require any help in supporting vst 2.4 speaker negotiation, it shouldn't take long code the support for it.

Andrew Simper"

http://www.kvraudio.com/forum/viewtopic.php?p=3754036

So if anyone wants to have a look at it that'd be awesome.

Offline Saga Musix

  • OpenMPT Developers
  • *****
  • Posts: 6,252
  • aka Jojo
    • Download music, samples, VST plugins: Saga Musix Website
  • Operating System: Windows 7 x64
.52 Problem with VST2.4 plugin
« Reply #1 on: September 09, 2009, 18:18:28 »
I think OpenMPT supports the VST specs up to v2.3, so it would be only natural that the plugin doesn't work correctly. ModPlug also doesn't have a bus and only supports 2 inputs (stereo). I'm afraid you can't use sidechain compressors in OpenMPT directly.
» No support, bug reports, feature requests via private messages - they will not be answered. Use the forums and the issue tracker so that everyone can benefit from your post.

Offline seventhson

  • Inspired artist
  • **
  • Posts: 88
.52 Problem with VST2.4 plugin
« Reply #2 on: September 09, 2009, 18:54:23 »
I remember using compressors that had sidechaining as well, they worked fine except you couldn't use sidechaining (obviously), but that might be because of different programming by the dev.
Are there any plans on implementing the VST 2.4 specs?

Offline Saga Musix

  • OpenMPT Developers
  • *****
  • Posts: 6,252
  • aka Jojo
    • Download music, samples, VST plugins: Saga Musix Website
  • Operating System: Windows 7 x64
.52 Problem with VST2.4 plugin
« Reply #3 on: September 09, 2009, 19:01:23 »
Sorry, those two explanations were not related. Sidechaining isn't new in the 2.4 specs, but this compressor seems to make use of additional new features. I won't be the one who adds support for VST 2.4, so I cannot say if there is a plan on implmenting it.
» No support, bug reports, feature requests via private messages - they will not be answered. Use the forums and the issue tracker so that everyone can benefit from your post.

Offline Saga Musix

  • OpenMPT Developers
  • *****
  • Posts: 6,252
  • aka Jojo
    • Download music, samples, VST plugins: Saga Musix Website
  • Operating System: Windows 7 x64
Re: .52 Problem with VST2.4 plugin
« Reply #4 on: December 23, 2010, 22:09:29 »
Actually the plugin loads fine here in any version of OpenMPT I've tried (1.17.02.54 and newer). That doesn't mean that sidechaining will work, but that's a different story anyway.
» No support, bug reports, feature requests via private messages - they will not be answered. Use the forums and the issue tracker so that everyone can benefit from your post.