Author Topic: 1.17.02.52 samples clip when previewed in samples tab  (Read 4080 times)

Offline anboi

  • Inspired artist
  • **
  • Posts: 94
    • http://greenbank.zombierobotsfromouterspace.com/
1.17.02.52 samples clip when previewed in samples tab
« on: August 20, 2008, 19:07:58 »
Full Version:
OpenMPT v1.17.02.52
spotted it in .48 but checked in .52 where it also occurs


Description of the bug:

If the mixmode RC3 is used and a sample is previewed in the samples pane with the initial global volume set at 0db (128) then the sample clips causing distortion. this doesn't occur when the sample is previewed as an instrument in the instrument tab.

How often does it happen?:
all the time

How to reproduce (step by step description):
start a new track
make sure mixmode is RC3
set initial global volume to 128 (0dB)
leave the sample volume at 128 (0dB) as well
load in a sample that peaks at 0dB or a very small margin less than this
play this sample in the sample tab
you should notice that this sounds louder and slightly distorted compared to it playing in a track or being previewed as an instrument.

i double checked this by recording the output from modplug and the sample clips quite noticeably.
if the initial global volume is reduced then this problem stops occuring but there should not be clipping when everything is less than or equal to 0dB
there's even a difference in volume between sample and instrument previews when the default value of 64 is used for the initial global volume but the clipping is reduced.

Offline psishock

  • Extreme artist
  • *****
  • Posts: 1,296
  • Gender: Male
  • Operating System: win8(64)
.52 samples clip when previewed in samples tab
« Reply #1 on: August 20, 2008, 20:09:04 »
I've checked the issue, here is what i've found out:
If you set the sample volume (or leave from start) to 128 (+0db) you will get EXACTLY the half of its "strength" in instrument tab. Try to set the global sample volume in general tab to maximum 256 (+6.93db), you will get the exact same volume of the sound in sample payback as in instrument playback.
The solution of my research together with your report to clipping "if the sample peaks near 0 db", is that the sample tab playback most likely  seems that allways uses the maximux extra (+6.93db) for playback, no matter what you set in "sample playback" volume in general tab, and the instrument of the sample seems to play it in the most proper way, and follows the settings.
Because of this (and many other reasons) i reccommend that you use instruments in your songs, rather than samples, but if thats not available to you for any reason, setting "Global Volume" in "Samples tab" to 32 can be a solution for you. That will get you the proper (+0db) playback without clipping on loud (near 0db peaks samples), narutally setting it to 0 will make it silent and leaving it on 64 will give the (+6.93db) boost (and will clip naturally on loud samples =).

Hope that it helps. ;)
I'm as calm as a synth without a player.  (Sam_Zen)

Offline psishock

  • Extreme artist
  • *****
  • Posts: 1,296
  • Gender: Male
  • Operating System: win8(64)
.52 samples clip when previewed in samples tab
« Reply #2 on: August 22, 2008, 11:31:43 »
Quote
if the initial global volume is reduced then this problem stops occuring

Also i forgot to mention one more (kinda important) thing, don't be mistaken with the "initial global volume", it affects ONLY the final mixing volume db. In other words, if your samples (and this applies to instruments too) are clipping inside your songs because of the high db boost, reducing the "initial global volume" wont help you at all (just won't hear that distorted sound that loud =).
(multi checked with a fft spectrum analyzer, those db values don't move even a tiny bit, no matter what you set on "initial global volume")
I'm as calm as a synth without a player.  (Sam_Zen)

Offline Saga Musix

  • OpenMPT Developers
  • *****
  • Posts: 6,248
  • aka Jojo
    • Download music, samples, VST plugins: Saga Musix Website
  • Operating System: Windows 7 x64
.52 samples clip when previewed in samples tab
« Reply #3 on: March 10, 2009, 23:24:25 »
I can only confirm this and I guess that something has to be done about either mixmode RC3 or the sample tab volume.
» No support, bug reports, feature requests via private messages - they will not be answered. Use the forums and the issue tracker so that everyone can benefit from your post.

Offline LPChip

  • Administrator
  • *****
  • Posts: 4,956
    • http://lpchip.nl
  • Operating System: Windows 10 Pro N (x64bit)
.52 samples clip when previewed in samples tab
« Reply #4 on: March 11, 2009, 13:38:46 »
I vote for the sample tab, because it always happened. Just not this badly since RC3.
"Heh, maybe I should've joined the compo only because it would've meant I wouldn't have had to worry about a damn EQ or compressor for a change. " - Atlantis
"yes.. I think in this case it was wishful thinking: MPT is makng my life hard so it must be wrong" - Rewbs

Offline Saga Musix

  • OpenMPT Developers
  • *****
  • Posts: 6,248
  • aka Jojo
    • Download music, samples, VST plugins: Saga Musix Website
  • Operating System: Windows 7 x64
.52 samples clip when previewed in samples tab
« Reply #5 on: March 11, 2009, 13:44:03 »
It always happened? With default settings, the sample tab's preview never clipped. Anyway, I guess that the global volume of the mod should probably not taked into conisderation on the sample tab - rather a fixed volume should be used here.
» No support, bug reports, feature requests via private messages - they will not be answered. Use the forums and the issue tracker so that everyone can benefit from your post.

Offline Saga Musix

  • OpenMPT Developers
  • *****
  • Posts: 6,248
  • aka Jojo
    • Download music, samples, VST plugins: Saga Musix Website
  • Operating System: Windows 7 x64
.52 samples clip when previewed in samples tab
« Reply #6 on: March 17, 2009, 15:58:11 »
Enabling the "no loud samples" option in the settings sounds better with RC3 mixmode, BTW.
» No support, bug reports, feature requests via private messages - they will not be answered. Use the forums and the issue tracker so that everyone can benefit from your post.

Offline Saga Musix

  • OpenMPT Developers
  • *****
  • Posts: 6,248
  • aka Jojo
    • Download music, samples, VST plugins: Saga Musix Website
  • Operating System: Windows 7 x64
Re: 1.17.02.52 samples clip when previewed in samples tab
« Reply #7 on: March 24, 2012, 13:50:10 »
Gonna close this report since "no loud samples" is enabled by default now and sane default volume settings are used again.
» No support, bug reports, feature requests via private messages - they will not be answered. Use the forums and the issue tracker so that everyone can benefit from your post.